Click or drag to resize

GH_InstanceDescriptionRead Method

Default deserialization. Only retrieves Name, NickName, Description and InstanceGuid fields. If you want to retrieve additional fields use ReadFull() instead. However, ReadFull() will only work if the archive was written using WriteFull().

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public virtual bool Read(
	GH_IReader reader
)

Parameters

reader
Type: GH_IO.SerializationGH_IReader
Object to deserialize with.

Return Value

Type: Boolean
Always True.

Implements

GH_ISerializableRead(GH_IReader)
See Also