Click or drag to resize

Node3dTCollapseNodes Method

Collapse the (sub)tree rooted at this node. Collapsing happens when a node only has a single child, in which case the child usurps the position previously held by the parent. Do not collapse a (sub)tree if you still plan to add items later.

Namespace:  Grasshopper.Kernel.Geometry.SpatialTrees
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public Node3d<T> CollapseNodes()

Return Value

Type: Node3dT
The new root for this (sub)tree. May well be an instance of this node if it cannot be collapsed.
See Also