Click or drag to resize

Node3dTOptimizeTree Method

Optimize this tree for fast searches. Do not call this method if you still plan to add items in the future. You can no longer modify this tree once it has been optimized.

Namespace:  Grasshopper.Kernel.Geometry.SpatialTrees
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public Node3d<T> OptimizeTree()

Return Value

Type: Node3dT
The new root of the optimized tree. If the root could not be optimized an instance of this node will be returned.
See Also