Click or drag to resize

GH_GeometricGooTTransform Method

Transforms the object or a deformable representation of the object.

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract IGH_GeometricGoo Transform(
	Transform xform
)

Parameters

xform
Type: Transform
Transformation matrix.

Return Value

Type: IGH_GeometricGoo
Transformed geometry. If the local geometry can be transformed accurately, then the returned instance equals this instance. Not all geometry types can be accurately transformed under all circumstances though, if this is the case, this function will return an instance of another IGH_GeometricGoo derived type which can be transformed.

Implements

IGH_GeometricGooTransform(Transform)
See Also