Click or drag to resize

GH_GeometricGooT Methods

The GH_GeometricGooT generic type exposes the following members.

Methods
  NameDescription
Public methodCastFrom
Attempt a cast from generic object.
(Overrides GH_GooTCastFrom(Object).)
Public methodCastToQ(Q)
Attempt a cast to type T.
(Overrides GH_GooTCastToQ(Q).)
Public methodClearCaches
Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value.
Public methodDuplicate
Make a complete duplicate of this instance. No shallow copies.
(Overrides GH_GooTDuplicate.)
Public methodDuplicateGeometry
Make a complete duplicate of this geometry. No shallow copies.
Public methodEmitProxy
Create a new proxy for this instance. Return Null if this class does not support proxies.
(Overrides GH_GooTEmitProxy.)
Public methodGetBoundingBox
Compute an aligned boundingbox.
Public methodLoadGeometry
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public methodLoadGeometry(RhinoDoc)
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.
Public methodMorph
Morph the object or a deformable representation of the object.
Public methodTransform
Transforms the object or a deformable representation of the object.
Top
See Also