Click or drag to resize

GH_InputParamManager Methods

The GH_ComponentGH_InputParamManager type exposes the following members.

Methods
  NameDescription
Public methodAddAngleParameter(String, String, String, GH_ParamAccess)
Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.
Public methodAddAngleParameter(String, String, String, GH_ParamAccess, IEnumerableDouble)
Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.
Public methodAddAngleParameter(String, String, String, GH_ParamAccess, Double)
Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.
Public methodAddArcParameter(String, String, String, GH_ParamAccess)
Add a 3D Arc parameter to the input list of this component.
Public methodAddArcParameter(String, String, String, GH_ParamAccess, Arc)
Add a 3D Arc parameter to the input list of this component.
Public methodAddBooleanParameter(String, String, String, GH_ParamAccess)
Add a Boolean parameter to the input list of this component.
Public methodAddBooleanParameter(String, String, String, GH_ParamAccess, Boolean)
Add a Boolean parameter to the input list of this component.
Public methodAddBooleanParameter(String, String, String, GH_ParamAccess, IEnumerableBoolean)
Add a Boolean parameter to the input list of this component.
Public methodAddBoxParameter(String, String, String, GH_ParamAccess)
Add a 3D Box parameter to the input list of this component.
Public methodAddBoxParameter(String, String, String, GH_ParamAccess, Box)
Add a 3D Box parameter to the input list of this component.
Public methodAddBrepParameter
Add a 3D Brep parameter to the input list of this component. Brep parameters can handle both trimmed and untrimmed single or multi-faced Breps.
Public methodAddCircleParameter(String, String, String, GH_ParamAccess)
Add a 3D Circle parameter to the input list of this component.
Public methodAddCircleParameter(String, String, String, GH_ParamAccess, Circle)
Add a 3D Circle parameter to the input list of this component.
Public methodAddColourParameter(String, String, String, GH_ParamAccess)
Add an ARGB Colour parameter to the input list of this component.
Public methodAddColourParameter(String, String, String, GH_ParamAccess, IEnumerableColor)
Add an ARGB Colour parameter to the input list of this component.
Public methodAddColourParameter(String, String, String, GH_ParamAccess, Color)
Add an ARGB Colour parameter to the input list of this component.
Public methodAddComplexNumberParameter(String, String, String, GH_ParamAccess)
Add a Complex Number parameter to the input list of this component.
Public methodAddComplexNumberParameter(String, String, String, GH_ParamAccess, GH_ComplexNumber)
Add a Complex Number parameter to the input list of this component.
Public methodAddCultureParameter(String, String, String, GH_ParamAccess)
Add a Cultue parameter to the input list of this component.
Public methodAddCultureParameter(String, String, String, GH_ParamAccess, CultureInfo)
Add a Culture parameter to the input list of this component.
Public methodAddCurveParameter
Add a 3D Curve parameter to the input list of this component. Curve parameters can handle all curve types (Lines, Polylines, Circles, Arcs, NurbsCurves etc.)
Public methodAddFieldParameter
Add a Field parameter to the input list of this component.
Public methodAddGenericParameter
Add a Generic parameter to the input list of this component. Generic parameters can handle all types of data.
Public methodAddGeometryParameter
Add a generic 3D Geometry parameter to the input list of this component. Geometry parameters can handle all types that represent actual shapes.
Public methodAddGroupParameter
Add a Transform Group parameter to the input list of this component. Groups are collections of geometry that are transformed as one, they are not the same as Rhino groups.
Public methodAddIntegerParameter(String, String, String, GH_ParamAccess)
Add a Integer parameter to the input list of this component.
Public methodAddIntegerParameter(String, String, String, GH_ParamAccess, IEnumerableInt32)
Add a Integer parameter to the input list of this component.
Public methodAddIntegerParameter(String, String, String, GH_ParamAccess, Int32)
Add a Integer parameter to the input list of this component.
Public methodAddInterval2DParameter
Add an Interval2D (i.e. uv domain) parameter to the input list of this component.
Public methodAddIntervalParameter(String, String, String, GH_ParamAccess)
Add an Interval (i.e. numeric domain) parameter to the input list of this component.
Public methodAddIntervalParameter(String, String, String, GH_ParamAccess, Interval)
Add an Interval (i.e. numeric domain) parameter to the input list of this component.
Public methodAddIntervalParameter(String, String, String, GH_ParamAccess, IEnumerableInterval)
Add an Interval (i.e. numeric domain) parameter to the input list of this component.
Public methodAddLineParameter(String, String, String, GH_ParamAccess)
Add a 3D Line parameter to the input list of this component.
Public methodAddLineParameter(String, String, String, GH_ParamAccess, Line)
Add a 3D Line parameter to the input list of this component.
Public methodAddMatrixParameter
Add a Matrix parameter to the input list of this component.
Public methodAddMeshFaceParameter
Add a topological MeshFace parameter to the input list of this component.
Public methodAddMeshParameter
Add a 3D Mesh parameter to the input list of this component.
Public methodAddNumberParameter(String, String, String, GH_ParamAccess)
Add a floating point Number parameter to the input list of this component.
Public methodAddNumberParameter(String, String, String, GH_ParamAccess, IEnumerableDouble)
Add a floating point Number parameter to the input list of this component.
Public methodAddNumberParameter(String, String, String, GH_ParamAccess, Double)
Add a floating point Number parameter to the input list of this component.
Public methodAddParameter(IGH_Param)
Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public methodAddParameter(IGH_Param, String, String, String, GH_ParamAccess)
Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public methodAddPathParameter
Add a Data Path parameter to the input list of this component.
Public methodAddPlaneParameter(String, String, String, GH_ParamAccess)
Add a 3D Plane parameter to the input list of this component.
Public methodAddPlaneParameter(String, String, String, GH_ParamAccess, Plane)
Add a 3D Plane parameter to the input list of this component.
Public methodAddPointParameter(String, String, String, GH_ParamAccess)
Add a 3D Point parameter to the input list of this component.
Public methodAddPointParameter(String, String, String, GH_ParamAccess, Point3d)
Register a new 3D point param with a single default coordinate.
Public methodAddPointParameter(String, String, String, GH_ParamAccess, IEnumerablePoint3d)
Register a new 3D point param with multiple default coordinates.
Public methodAddRectangleParameter(String, String, String, GH_ParamAccess)
Add a 3D Rectangle parameter to the input list of this component.
Public methodAddRectangleParameter(String, String, String, GH_ParamAccess, Rectangle3d)
Add a 3D Rectangle parameter to the input list of this component.
Public methodAddScriptVariableParameter
Add a Script Variable parameter to the input list of this component. Script variable parameters are used almost exclusively in VB/C#/Python components so you probably don't want this one.
Public methodAddSubDParameter
Add a 3D Sub-D parameter to the input list of this component.
Public methodAddSurfaceParameter
Add a 3D Surface parameter to the input list of this component. Surface parameters can handle both trimmed and untrimmed single-faced Breps.
Public methodAddTextParameter(String, String, String, GH_ParamAccess)
Add a Text parameter to the input list of this component.
Public methodAddTextParameter(String, String, String, GH_ParamAccess, IEnumerableString)
Add a Text parameter to the input list of this component.
Public methodAddTextParameter(String, String, String, GH_ParamAccess, String)
Add a Text parameter to the input list of this component.
Public methodAddTimeParameter(String, String, String, GH_ParamAccess)
Add a Time parameter to the input list of this component.
Public methodAddTimeParameter(String, String, String, GH_ParamAccess, DateTime)
Add a Time parameter to the input list of this component.
Public methodAddTransformParameter
Add a Transformation parameter to the input list of this component.
Public methodAddVectorParameter(String, String, String, GH_ParamAccess)
Add a 3D Vector parameter to the input list of this component.
Public methodAddVectorParameter(String, String, String, GH_ParamAccess, Vector3d)
Add a 3D Vector parameter to the input list of this component.
Public methodHideParameter
Hide a specific input parameter. If the parameter at the given index implements IGH_PreviewObject then the Hidden flag will be set to True. Otherwise, nothing will happen.
(Overrides GH_ParamManager.HideParameter(Int32).)
Top
See Also