Click or drag to resize

IGH_Param Methods

The IGH_Param type exposes the following members.

Methods
  NameDescription
Public methodAddSource(IGH_Param)
Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime.
Public methodAddSource(IGH_Param, Int32)
Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime.
Public methodAddVolatileData
Inserts an item of volatile data into the data structure.
Public methodAddVolatileDataList
Inserts a list of items into the data structure.
Public methodAddVolatileDataTree
Insert an entire data tree into this parameter.
Public methodClearProxySources
Remove all proxy sources without attempting to relink them.
Public methodCreateProxySources
Convert all proper source parameters into proxy sources.
Public methodRelinkProxySources
Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public methodRemoveAllSources
Remove all sources from this parameter.
Public methodRemoveEffects
Remove all post-process effects.
Public methodRemoveSource(Guid)
Remove the specified source from this parameter.
Public methodRemoveSource(IGH_Param)
Remove the specified source from this parameter.
Public methodReplaceSource(Guid, IGH_Param)
Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public methodReplaceSource(IGH_Param, IGH_Param)
Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Top
See Also