Click or drag to resize

GH_ChunkChunkKeyedCollection Class

Represents a collection of chunks with associated IDs
Inheritance Hierarchy
SystemObject
  GH_IO.SerializationGH_ChunkChunkKeyedCollection

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public class ChunkKeyedCollection : IEnumerable<GH_Chunk>, 
	IEnumerable

The GH_ChunkChunkKeyedCollection type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyCount
Returns the amount in the collection.
Top
Methods
  NameDescription
Public methodAdd
Adds a new chunk.
Public methodClear
Removes all chunks from the collection.
Public methodGetEnumerator
Gets an enumerator that iterates over all chunks in the collection.
Public methodRemove(GH_Chunk)
Removes a chunk.
Public methodRemove(ID)
Removes an ID.
Public methodTryGetValue
Try and find the chunk that belongs to a given ID.
Top
See Also