Click or drag to resize

GH_IReader Interface

Provides access to a subset of GH_Chunk methods used for reading archives.

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public interface GH_IReader : GH_IChunk, 
	GH_IBinarySupport, GH_IXmlSupport

The GH_IReader type exposes the following members.

Properties
  NameDescription
Top
Methods
  NameDescription
Public methodChunkExists(String)
Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodChunkExists(String, Int32)
Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodFindChunk(String)
Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered.
Public methodFindChunk(String, Int32)
Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered.
Public methodFindItem(String)
Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodFindItem(String, Int32)
Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodGetBoolean(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetBoolean(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetBoundingBox(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetBoundingBox(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetByte(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetByte(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetByteArray(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetByteArray(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDate(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDate(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDecimal(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDecimal(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDouble(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDouble(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDoubleArray(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDoubleArray(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingBitmap(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingBitmap(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingColor(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingColor(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingPoint(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingPoint(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingPointF(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingPointF(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingRectangle(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingRectangle(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingRectangleF(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingRectangleF(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingSize(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingSize(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingSizeF(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingSizeF(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetGuid(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetGuid(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetInt32(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetInt32(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetInt64(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetInt64(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetInterval1D(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetInterval1D(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetInterval2D(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetInterval2D(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetLine(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetLine(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetPath(String, String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetPath(String, Int32, String)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetPlane(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetPlane(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetPoint2D(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetPoint2D(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetPoint3D(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetPoint3D(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetPoint4D(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetPoint4D(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetSingle(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetSingle(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetString(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetString(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetVersion(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetVersion(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodItemExists(String)
Checks whether an item with the specified name exists. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodItemExists(String, Int32)
Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodTryGetBoolean(String, Boolean)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetBoolean(String, Int32, Boolean)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetBoundingBox(String, GH_BoundingBox)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetBoundingBox(String, Int32, GH_BoundingBox)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetByte(String, Byte)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetByte(String, Int32, Byte)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDate(String, DateTime)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDate(String, Int32, DateTime)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDecimal(String, Decimal)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDecimal(String, Int32, Decimal)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDouble(String, Double)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDouble(String, Int32, Double)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingColor(String, Color)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingColor(String, Int32, Color)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingPoint(String, Point)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingPoint(String, Int32, Point)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingPointF(String, PointF)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingPointF(String, Int32, PointF)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingRectangle(String, Rectangle)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingRectangle(String, Int32, Rectangle)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingRectangleF(String, RectangleF)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingRectangleF(String, Int32, RectangleF)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingSize(String, Size)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingSize(String, Int32, Size)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingSizeF(String, SizeF)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingSizeF(String, Int32, SizeF)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetGuid(String, Guid)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetGuid(String, Int32, Guid)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetInt32(String, Int32)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetInt32(String, Int32, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetInt64(String, Int64)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetInt64(String, Int32, Int64)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetInterval1D(String, GH_Interval1D)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetInterval1D(String, Int32, GH_Interval1D)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetInterval2D(String, GH_Interval2D)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetInterval2D(String, Int32, GH_Interval2D)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetLine(String, GH_Line)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetLine(String, Int32, GH_Line)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetPlane(String, GH_Plane)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetPlane(String, Int32, GH_Plane)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetPoint2D(String, GH_Point2D)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetPoint2D(String, Int32, GH_Point2D)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetPoint3D(String, GH_Point3D)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetPoint3D(String, Int32, GH_Point3D)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetPoint4D(String, GH_Point4D)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetPoint4D(String, Int32, GH_Point4D)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetSingle(String, Single)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetSingle(String, Int32, Single)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetString(String, String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetString(String, Int32, String)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetVersion(String, GH_Version)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetVersion(String, Int32, GH_Version)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Top
See Also