Click or drag to resize

GH_IChunk Interface

Base interface for all Archive Chunks.

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public interface GH_IChunk : GH_IBinarySupport, 
	GH_IXmlSupport

The GH_IChunk type exposes the following members.

Properties
  NameDescription
Public propertyArchive
Gets a pointer to the archive that owns the Root of the tree this chunk belongs to.
Public propertyArchiveLocation
Gets a string representing the URI with which the archive is associated. The location may be a null string.
Public propertyChunkCount
Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'.
Public propertyChunks
Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing.
Public propertyIndex
Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter.
Public propertyItemCount
Gets the number of items contained in this chunk.
Public propertyItems
Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing.
Public propertyName
Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter.
Top
Methods
  NameDescription
Public methodAddMessage
Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog().
Top
See Also