Click or drag to resize

GH_ActiveObject Properties

The GH_ActiveObject type exposes the following members.

Properties
  NameDescription
Public propertyIconCapableUI
By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False.
Public propertyIsDataProvider
Returns a boolean indicating whether or not the current object can seed data.
Public propertyLocked
Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions.
Public propertyMutableNickName
Gets or sets a value that enables Nick name changes through the menu. The default is TRUE.
Public propertyPhase
Gets or sets the solution phase this object is currenly in.
Public propertyProcessorTime
Gets the most recent processor time profiler value.
Public propertyRuntimeMessageLevel
Returns the worst case flag for the current object

If the object contains at least 1 error, the result is Error.

If the object contains at least 1 warning, the result is Warning.

If the object contains at least 1 message, the result is Remark.

If the object contains no errors, no warnings and no messages, the result is Blank.

Top
See Also