Click or drag to resize

GH_ConnectivityDiagram Class

Represents a complete connectivity diagram (topology) of a GH_Document. A connectivity diagram is basically an undirected network of all the wires in a document.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_ConnectivityDiagram

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ConnectivityDiagram

The GH_ConnectivityDiagram type exposes the following members.

Constructors
  NameDescription
Public methodGH_ConnectivityDiagram(GH_ConnectivityDiagram)
Create a duplicate of another Connectivity Diagram.
Public methodGH_ConnectivityDiagram(GH_Document)
Create a new Connectivity Diagram from a GH_Document.
Top
Properties
  NameDescription
Public propertyNode
Get the connectivity node with the specified ID.
Public propertyNodeCount
Gets the number of connectivity nodes in this diagram.
Public propertyNodes
Gets a proxy for all the Nodes in this diagram.
Top
Methods
  NameDescription
Public methodContainsID
Test the diagram for a given Node ID.
Public methodGetAllInputs
Get all the Nodes that are part of the specified node input.
Public methodGetAllOutputs
Get all the Nodes that are part of the specified node output.
Top
See Also