Click or drag to resize

GH_ConnectivityDisparity Class

Maintains two connectivity diagrams, one of which is a subset of the other.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_ConnectivityDisparity

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ConnectivityDisparity

The GH_ConnectivityDisparity type exposes the following members.

Constructors
  NameDescription
Public methodGH_ConnectivityDisparity
Create a new instance of the Connectivity Disparity utility class.
Top
Properties
  NameDescription
Public propertySubNodes
Gets a proxy for all the Nodes in the Subset diagram.
Public propertySubSet
Gets a pointer to the subset diagram stored in this disparity class.
Public propertyTopNodes
Gets a proxy for all the Nodes in the Top Level diagram.
Public propertyTopSet
Gets a pointer to the complete diagram stored in this disparity class.
Top
Methods
  NameDescription
Public methodExternalInputs
Find all external sources for a given id in the subset.
Public methodExternalOutputs
Find all external recipients for a given id in the subset.
Public methodInternalInputs
Find all internal sources for a given id in the subset.
Public methodInternalOutputs
Find all external recipients for a given id in the subset.
Top
See Also