Description:

Adds a new DimensionStyle to the document.

Syntax:
public int Add(
DimensionStyle dimstyle,
bool reference
)
Parameters:
  • reference
  • Type: bool
  • if True the dimstyle will not be saved in files.
Returns:
Type: int
index of new AnnotationStyle.
Available since:
6.0

Description:

Adds a new AnnotationStyle to the document. The new AnnotationStyle will be initialized with the current default AnnotationStyle properties.

Syntax:
public int Add(
string name,
bool reference
)
Parameters:
  • name
  • Type: string
  • Name of the new AnnotationStyle. If None or empty, Rhino automatically generates the name.
  • reference
  • Type: bool
  • if True the dimstyle will not be saved in files.
Returns:
Type: int
index of new AnnotationStyle.
Available since:
5.0

Description:

Adds a new AnnotationStyle to the document. The new AnnotationStyle will be initialized with the current default AnnotationStyle properties.

Syntax:
public int Add(
string name
)
Parameters:
  • name
  • Type: string
  • Name of the new AnnotationStyle. If None or empty, Rhino automatically generates the name.
Returns:
Type: int
index of new AnnotationStyle.
Available since:
5.0

Nothing found