Description:

Adds a new hatch pattern with specified definition to the table.

Syntax:
public int Add(
HatchPattern pattern
)
Parameters:
  • pattern
  • Type: Rhino.DocObjects.HatchPattern
  • definition of new hatch pattern. The information in pattern is copied. If pattern.Name is empty the a unique name of the form "HatchPattern 01" will be automatically created.
Returns:
Type: int
>=0 index of new hatch pattern -1 not added because a hatch pattern with that name already exists or some other problem occurred.
Available since:
5.0

Nothing found