Description:

DollyCamera() does not update the frustum's clipping planes. To update the frustum's clipping planes call DollyFrustum(d) with d = dollyVector o cameraFrameZ. To convert screen locations into a dolly vector, use GetDollyCameraVector(). Does not update frustum. To update frustum use DollyFrustum(d) with d = dollyVector o cameraFrameZ.

Syntax:
public bool DollyCamera(
Vector3d dollyVector
)
Parameters:
  • dollyVector
  • Type: Vector3d
  • dolly vector in world coordinates.
Returns:
Type: bool
True if the operation succeeded; otherwise, false.
Available since:
5.0

DollyCamera method

Class:  Rhino.DocObjects.ViewportInfo

Nothing found