Description:

Gets the corners of the frame plane rectangle at specified depth. 4 points are returned in the order of bottom left, bottom right, top left, top right.

Syntax:
public Point3d[] GetFramePlaneCorners(
double depth
)
Parameters:
  • depth
  • Type: double
  • Distance from camera location.
Returns:
Type: Point3d[]
Four corner points on success. Empty array if viewport is not valid.
Available since:
8.0

/
/
/
GetFramePlaneCorners

GetFramePlaneCorners method

Class:  Rhino.DocObjects.ViewportInfo

Nothing found