Description:

Gets a world coordinate dolly vector that can be passed to DollyCamera().

Syntax:
public Vector3d GetDollyCameraVector(
int screenX0,
int screenY0,
int screenX1,
int screenY1,
double projectionPlaneDistance
)
Parameters:
  • screenX0
  • Type: int
  • Screen coordinates of start point.
  • screenY0
  • Type: int
  • Screen coordinates of start point.
  • screenX1
  • Type: int
  • Screen coordinates of end point.
  • screenY1
  • Type: int
  • Screen coordinates of end point.
  • projectionPlaneDistance
  • Type: double
  • Distance of projection plane from camera. When in doubt, use 0.5*(frus_near+frus_far).
Returns:
Type: Vector3d
The world coordinate dolly vector.
Available since:
5.0

Description:

Gets a world coordinate dolly vector that can be passed to DollyCamera().

Syntax:
public Vector3d GetDollyCameraVector(
Point screen0,
Point screen1,
double projectionPlaneDistance
)
Parameters:
  • projectionPlaneDistance
  • Type: double
  • Distance of projection plane from camera. When in doubt, use 0.5*(frus_near+frus_far).
Returns:
Type: Vector3d
The world coordinate dolly vector.
Available since:
5.0

/
/
/
GetDollyCameraVector

GetDollyCameraVector method

Class:  Rhino.DocObjects.ViewportInfo

Nothing found