Description:

Zooms to a screen zone. View changing from screen input points. Handy for using a mouse to manipulate a view. ZoomToScreenRect() may change camera and frustum settings.

Syntax:
public bool ZoomToScreenRect(
int left,
int top,
int right,
int bottom
)
Parameters:
  • left
  • Type: int
  • Screen coordinate.
  • top
  • Type: int
  • Screen coordinate.
  • right
  • Type: int
  • Screen coordinate.
  • bottom
  • Type: int
  • Screen coordinate.
Returns:
Type: bool
True if the operation succeeded; otherwise, false.
Available since:
5.0

Description:

Zooms to a screen zone. View changing from screen input points. Handy for using a mouse to manipulate a view. ZoomToScreenRect() may change camera and frustum settings.

Syntax:
public bool ZoomToScreenRect(
Rectangle windowRectangle
)
Parameters:
  • windowRectangle
  • Type: System.Drawing.Rectangle
  • The new window rectangle in screen space.
Returns:
Type: bool
True if the operation succeeded; otherwise, false.
Available since:
5.0

ZoomToScreenRect method

Class:  Rhino.DocObjects.ViewportInfo

Nothing found