Description:

Returns localized version of a given English string. This function should be auto-generated by the RmaLDotNetLocalizationProcessor application for every function that uses RMASTR.

Syntax:
public static string LocalizeString(
string english,
int contextId
)
Parameters:
  • english
  • Type: string
  • The text in English.
  • contextId
  • Type: int
  • The context ID.
Returns:
Type: string
The localized string.
Available since:
5.0

Description:

DO NOT use this function, it is a trap to determine where context IDs have been copied from other, already extracted, strings.

Syntax:
public static string LocalizeString(
string english,
int wrongcontextId,
int contextId
)
deprecated in 7.1
obsolete: Don't copy and paste context IDs", true
Parameters:
  • english
  • Type: string
  • The text in English.
  • wrongcontextId
  • Type: int
  • The copied ID.
  • contextId
  • Type: int
  • The context ID.
Returns:
Type: string
The english string.
Available since:
7.0

Description:

Returns localized version of a given English string. This function should be auto-generated by the RmaLDotNetLocalizationProcessor application for every function that uses RMASTR.

Syntax:
public static string LocalizeString(
string english,
object assemblyOrObject,
int contextId
)
Parameters:
  • english
  • Type: string
  • The text in English.
  • assemblyOrObject
  • Type: object
  • An assembly or an object from an assembly.
  • contextId
  • Type: int
  • The context ID.
Returns:
Type: string
The localized string.
Available since:
5.0

/
/
/
LocalizeString

LocalizeString method

Class:  Rhino.UI.Localization

Nothing found