Rhino C++ API  8.6
Public Member Functions | Public Attributes | Friends | List of all members
CDisplayAttributeMaterial Class Reference

#include <rhinoSdkDisplayPipelineMaterial.h>

Inheritance diagram for CDisplayAttributeMaterial:
ON_Material ON_ModelComponent ON_Object

Public Member Functions

 CDisplayAttributeMaterial ()
 
 CDisplayAttributeMaterial (const CDisplayAttributeMaterial &)
 
 CDisplayAttributeMaterial (const ON_Material &)
 
 ~CDisplayAttributeMaterial ()
 
bool AppearanceEquals (const CDisplayAttributeMaterial &other) const
 
void Default ()
 
const CRhinoDocDocumentAssoc (void) const
 
unsigned int DocumentAssocRSN (void) const
 
void EnableMipMap (bool bEnable)
 
bool IsBakedMaterial () const
 
bool IsSelectionMapColor () const
 
bool MipMappingEnabled () const
 
CDisplayAttributeMaterialoperator= (const CDisplayAttributeMaterial &)
 
CDisplayAttributeMaterialoperator= (const ON_Material &src)
 
bool operator== (const CDisplayAttributeMaterial &) const
 
CDisplayAttributeMaterial_Private & Private ()
 
const CDisplayAttributeMaterial_Private & Private () const
 
void SetDocumentAssoc (const CRhinoDoc *pDoc)
 
void SetDocumentAssoc (unsigned int documentRuntimeSerialNumber)
 
void SetIsBakedMaterial (bool b)
 
void SetIsSelectionMapColor (bool b)
 
- Public Member Functions inherited from ON_Material
 ON_Material () ON_NOEXCEPT
 
 ON_Material (const ON_Material &src)
 
 ~ON_Material ()=default
 
int AddTexture (const ON_Texture &tx)
 
int AddTexture (const wchar_t *filename, ON_Texture::TYPE type)
 
ON_Color Ambient () const
 Interface. More...
 
int DeleteTexture (const wchar_t *filename, ON_Texture::TYPE type)
 
ON_Color Diffuse () const
 
bool DisableLighting () const
 
void Dump (ON_TextLog &text_log) const override
 
ON_Color Emission () const
 
int FindTexture (const wchar_t *filename, ON_Texture::TYPE type, int i0=-1) const
 
int FindTexture (ON_UUID texture_id) const
 
double FresnelReflectionCoefficient (ON_3dVector N, ON_3dVector R) const
 
bool FresnelReflections () const
 
bool IsPhysicallyBased (void) const
 
bool IsValid (class ON_TextLog *text_log=nullptr) const override
 ON_Object overrides. More...
 
const ON_UUID MaterialChannelIdFromIndex (int material_channel_index) const
 
int MaterialChannelIndexFromId (ON_UUID material_channel_id) const
 
int MaterialChannelIndexFromId (ON_UUID material_channel_id, bool bAddIdIfNotPresent)
 
ON_UUID MaterialPlugInId () const
 ID of the last plug-in to modify this material. More...
 
ON::object_type ObjectType () const override
 
ON_Materialoperator= (const ON_Material &src)=default
 
std::shared_ptr< ON_PhysicallyBasedMaterialPhysicallyBased (void)
 
const std::shared_ptr< ON_PhysicallyBasedMaterialPhysicallyBased (void) const
 
ON_Color PreviewColor () const
 
ON_UUID RdkMaterialInstanceId () const
 
bool RdkMaterialInstanceIdIsNil () const
 
bool RdkMaterialInstanceIdIsNotNil () const
 
bool Read (ON_BinaryArchive &archive) override
 
double Reflectivity () const
 Transparency values are in range 0.0 = opaque to 1.0 = transparent. More...
 
void SetAmbient (ON_Color)
 
void SetDiffuse (ON_Color)
 
void SetDisableLighting (bool bDisableLighting)
 
void SetEmission (ON_Color)
 
void SetFresnelReflections (bool bFresnelReflections)
 
void SetMaterialPlugInId (ON_UUID plugin_id)
 
void SetRdkMaterialInstanceId (ON_UUID rdk_material_instance_id)
 
void SetReflectivity (double)
 0.0 = opaque, 1.0 = transparent More...
 
void SetShareable (bool bShareable)
 
void SetShine (double)
 0 to ON_Material::MaxShine More...
 
void SetSpecular (ON_Color)
 
void SetTransparency (double)
 0.0 = opaque, 1.0 = transparent More...
 
void SetUseDiffuseTextureAlphaForObjectTransparencyTexture (bool bUseDiffuseTextureAlphaForObjectTransparencyTexture)
 
bool Shareable () const
 
double Shine () const
 Shine values are in range 0.0 to ON_Material::MaxShine. More...
 
ON_Color Specular () const
 
void ToPhysicallyBased (void)
 
double Transparency () const
 Transparency values are in range 0.0 = opaque to 1.0 = transparent. More...
 
bool UseDiffuseTextureAlphaForObjectTransparencyTexture () const
 
bool Write (ON_BinaryArchive &archive) const override
 
- Public Member Functions inherited from ON_ModelComponent
 ON_ModelComponent () ON_NOEXCEPT
 
 ON_ModelComponent (const ON_ModelComponent &source)
 
 ON_ModelComponent (ON_ModelComponent::Type component_type) ON_NOEXCEPT
 
 ON_ModelComponent (ON_ModelComponent::Type component_type, const ON_ModelComponent &source) ON_NOEXCEPT
 Locked status of source attributes is not copied to permit copy and modify operations. More...
 
 ~ON_ModelComponent ()=default
 
bool ChangeName (const wchar_t *new_name, class ON_ComponentManifest *manifest)
 
bool ClearComponentType ()
 
bool ClearId ()
 
bool ClearIndex ()
 
unsigned int ClearModelComponentAttributes (unsigned int attributes_filter)
 
bool ClearModelComponentStatus ()
 
bool ClearModelSerialNumber ()
 
bool ClearName ()
 
bool ClearParentId ()
 
int CompareName (const ON_UUID &other_parent_id, const wchar_t *other_name) const
 
int CompareName (const wchar_t *other_name) const
 
int CompareNameExact (const ON_UUID &other_parent_id, const wchar_t *other_name) const
 
int CompareNameExact (const wchar_t *other_name) const
 
ON_ModelComponent::Type ComponentType () const
 
bool ComponentTypeIsLocked () const
 
bool ComponentTypeIsSet () const
 
ON__UINT64 ContentVersionNumber () const
 
unsigned int CopyFrom (const ON_ModelComponent &src, unsigned int attributes_filter)
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const override
 
const ON_wString DeletedName () const
 
const ON_NameHashDeletedNameHash () const
 
bool DeletedNameIsSet () const
 
bool DeleteName ()
 
void Dump (ON_TextLog &) const override
 
bool EraseIdentification (bool bIgnoreLocks)
 
const wchar_tGetName (ON_wString &component_name) const
 
const ON_UUIDId () const
 
bool IdIsLocked () const
 
bool IdIsNil () const
 
bool IdIsNotNil () const
 
bool IdIsSet () const
 
const ON_UUIDIfIdIsNilSetId ()
 
int Index () const
 
int Index (int unset_index_value) const
 
bool IndexIsLocked () const
 
bool IndexIsSet () const
 
unsigned int InstanceDefinitionModelSerialNumber () const
 
bool IsDeleted () const
 
bool IsHidden () const
 
bool IsLocked () const
 
bool IsReferenceComponent () const
 
bool IsSystemComponent () const
 
bool IsValid (class ON_TextLog *text_log=nullptr) const override
 
void LockAllSettingsExceptName ()
 
void LockComponentType ()
 
void LockId ()
 
void LockIndex ()
 
void LockModelComponentStatus ()
 
void LockModelSerialNumber ()
 
void LockName ()
 
void LockParentId ()
 
ON_ComponentStatus ModelComponentStatus () const
 
bool ModelComponentStatusIsLocked () const
 
bool ModelComponentStatusIsSet () const
 
ON_UUID ModelObjectId () const override
 
unsigned int ModelSerialNumber () const
 
bool ModelSerialNumberIsLocked () const
 
bool ModelSerialNumberIsSet () const
 
const ON_wString Name () const
 
const wchar_tNameAsPointer () const
 
const ON_NameHashNameHash () const
 
bool NameIsEmpty () const
 
bool NameIsLocked () const
 
bool NameIsNotEmpty () const
 
bool NameIsSet () const
 
const ON_NameHash NewNameHash (const wchar_t *new_name) const
 
ON_ModelComponentoperator= (const ON_ModelComponent &source)
 
const ON_UUIDParentId () const
 
bool ParentIdIsLocked () const
 
bool ParentIdIsNil () const
 
bool ParentIdIsNotNil () const
 
bool ParentIdIsSet () const
 
bool ReadModelComponentAttributes (class ON_BinaryArchive &archive)
 
unsigned int ReferenceModelSerialNumber () const
 
ON__UINT64 RuntimeSerialNumber () const
 
const ON_UUIDSetAndLockId ()
 
bool SetAsSystemComponent ()
 
bool SetAsUnsetSystemComponent ()
 
bool SetComponentType (ON_ModelComponent::Type component_component_type)
 
bool SetDeletedModelComponentState (bool bDeleted, class ON_ComponentManifest *manifest)
 
void SetHiddenModelComponentState (bool bHidden)
 
const ON_UUIDSetId ()
 
bool SetId (const ON_UUID &component_id)
 
bool SetIdentification (const class ON_ComponentManifestItem &manifest_item, const wchar_t *manifest_name, bool bSetId, bool bParentId, bool bSetName, bool bSetIndex)
 
bool SetIndex (int component_index)
 
bool SetLocalizedSystemComponentName (const wchar_t *system_component_localized_name)
 
void SetLockedModelComponentState (bool bLocked)
 
bool SetModelComponentStatus (ON_ComponentStatus component_status)
 
bool SetModelSerialNumber (unsigned int model_serial_number)
 
bool SetModelSerialNumber (unsigned int model_serial_number, unsigned int reference_model_serial_number, unsigned int instance_definition_model_serial_number)
 
bool SetName (const wchar_t *component_name)
 
bool SetParentId (const ON_UUID &parent_id)
 
unsigned int SizeOf () const override
 
bool UndeleteName ()
 
bool WriteModelComponentAttributes (class ON_BinaryArchive &archive, unsigned int attributes_filter) const
 
- Public Member Functions inherited from ON_Object
 ON_Object () ON_NOEXCEPT
 
 ON_Object (const ON_Object &)
 
virtual ~ON_Object ()
 
virtual ON_AggregateComponentStatus AggregateComponentStatus () const
 
bool AttachUserData (class ON_UserData *pUserData)
 
unsigned int ClearAllComponentStates () const
 
virtual unsigned int ClearComponentStates (ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_clear) const
 
virtual unsigned int ClearComponentStates (ON_ComponentStatus states_to_clear) const
 
void CopyUserData (const ON_Object &source_object)
 
unsigned int CopyUserData (const ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution)
 
virtual bool DeleteComponents (const ON_COMPONENT_INDEX *ci_list, size_t ci_count)
 
virtual void DestroyRuntimeCache (bool bDelete=true)
 
bool DetachUserData (class ON_UserData *pUserData)
 
void EmergencyDestroy ()
 
class ON_UserDataFirstUserData () const
 
virtual unsigned int GetComponentsWithSetStates (ON_ComponentStatus states_filter, bool bAllEqualStates, ON_SimpleArray< ON_COMPONENT_INDEX > &components) const
 
class ON_UserDataGetUserData (const ON_UUID &userdata_uuid) const
 
bool GetUserString (const wchar_t *key, ON_wString &string_value) const
 
int GetUserStringKeys (ON_ClassArray< ON_wString > &user_string_keys) const
 
int GetUserStrings (ON_ClassArray< ON_UserString > &user_strings) const
 
bool IsCorrupt (bool bRepair, bool bSilentError, class ON_TextLog *text_log) const
 
bool IsKindOf (const ON_ClassId *pClassId) const
 
virtual void MarkAggregateComponentStatusAsNotCurrent () const
 
virtual void MemoryRelocate ()
 
void MoveUserData (ON_Object &source_object)
 
unsigned int MoveUserData (ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution, bool bDeleteAllSourceItems)
 
ON_Objectoperator= (const ON_Object &)
 
void PurgeUserData ()
 
virtual unsigned int SetComponentStates (ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_set) const
 
virtual unsigned int SetComponentStatus (ON_COMPONENT_INDEX component_index, ON_ComponentStatus status_to_copy) const
 
bool SetUserString (const wchar_t *key, const wchar_t *string_value)
 
int SetUserStrings (int count, const ON_UserString *user_strings, bool bReplace)
 
bool ThisIsNullptr (bool bSilentError) const
 
void TransformUserData (const class ON_Xform &xform)
 
virtual bool UpdateReferencedComponents (const class ON_ComponentManifest &source_manifest, const class ON_ComponentManifest &destination_manifest, const class ON_ManifestMap &manifest_map)
 
int UserStringCount () const
 

Public Attributes

bool m_bFlatShaded
 
bool m_bOverrideObjectColor
 
bool m_bOverrideObjectReflectivity
 
bool m_bOverrideObjectTransparency
 
int m_nBumpUnit
 
int m_nEmapUnit
 
int m_nLuminosity
 
int m_nShineIntensity
 
ON_SimpleArray< int > m_nTextureUnit
 
int m_nTransUnit
 
ON_Color m_selectShadeHighlight
 
- Public Attributes inherited from ON_Material
ON_Color m_ambient = ON_Color::Black
 
ON_Color m_diffuse = ON_Color::Gray126
 
ON_Color m_emission = ON_Color::Black
 
double m_fresnel_index_of_refraction = 1.56
 
double m_index_of_refraction = 1.0
 
ON_SimpleArray< ON_UuidIndexm_material_channel
 
ON_Color m_reflection = ON_Color::White
 
double m_reflection_glossiness = 0.0
 
double m_reflectivity = 0.0
 0.0 = none, 1.0 = 100% More...
 
double m_refraction_glossiness = 0.0
 
double m_shine = 0.0
 0.0 = none to GetMaxShine()=maximum More...
 
ON_Color m_specular = ON_Color::White
 
ON_ObjectArray< ON_Texturem_textures
 
double m_transparency = 0.0
 0.0 = opaque to 1.0 = transparent (1.0-alpha) More...
 
ON_Color m_transparent = ON_Color::White
 

Friends

class CDisplayMaterialMgr
 

Additional Inherited Members

- Public Types inherited from ON_Material
enum  : int { MaximumMaterialChannelIndex = 65535 }
 
- Public Types inherited from ON_ModelComponent
enum  Attributes : unsigned int {
  NoAttributes = 0U, ComponentSerialNumberAttribute = 0x0001U, TypeAttribute = 0x0002U, ModelSerialNumberAttribute = 0x0004U,
  IdAttribute = 0x0008U, IndexAttribute = 0x0010U, NameAttribute = 0x0020U, ParentIdAttribute = 0x0040U,
  DeletedNameAttribute = 0x0080U, ComponentStatusAttribute = 0x0100U, BinaryArchiveAttributes = 0x78U, AllAttributes = 0x1FFU,
  SystemComponentAttribute = 0x8000U
}
 
enum  Type : unsigned char {
  Type::Unset = 0, Type::Image = 1, Type::TextureMapping = 2, Type::Material = 3,
  Type::RenderMaterial = Material, Type::LinePattern = 4, Type::Layer = 5, Type::Group = 6,
  Type::TextStyle = 7, Type::DimStyle = 8, Type::RenderLight = 9, Type::HatchPattern = 10,
  Type::InstanceDefinition = 11, Type::ModelGeometry = 12, Type::HistoryRecord = 13, Type::RenderContent = 14,
  Type::EmbeddedFile = 15, Type::ObsoleteValue = 16, Type::SectionStyle = 17, Type::NumOf,
  Type::Mixed = 0xFE
}
 The ON_ModelComponent::Type enum has a value for each explicit component type and two special values, Unset and Mixed. Use an ON_ModelComponentTypeIterator instance to iterate over the ON_ModelComponent::Type values. /summary> More...
 
- Public Types inherited from ON_Object
enum  UserDataConflictResolution : unsigned char {
  UserDataConflictResolution::destination_object = 0, UserDataConflictResolution::source_object = 1, UserDataConflictResolution::source_copycount_gt = 2, UserDataConflictResolution::source_copycount_ge = 3,
  UserDataConflictResolution::destination_copycount_gt = 4, UserDataConflictResolution::destination_copycount_ge = 5, UserDataConflictResolution::delete_item = 6
}
 
- Static Public Member Functions inherited from ON_Material
static int Compare (const ON_Material &a, const ON_Material &b)
 compare everything except Index() value. More...
 
static int CompareAppearance (const ON_Material &a, const ON_Material &b)
 
static int CompareColorAttributes (const ON_Material &a, const ON_Material &b)
 
static int CompareNameAndIds (const ON_Material &a, const ON_Material &b)
 compare Id(), Name(), m_rdk_material_instance_id More...
 
static int CompareReflectionAttributes (const ON_Material &a, const ON_Material &b)
 
static int CompareTextureAttributes (const ON_Material &a, const ON_Material &b)
 
static int CompareTextureAttributesAppearance (const ON_Material &a, const ON_Material &b)
 
static double FresnelReflectionCoefficient (double fresnel_index_of_refraction, const double N[3], const double R[3])
 
static const ON_MaterialFromModelComponentRef (const class ON_ModelComponentReference &model_component_reference, const ON_Material *none_return_value)
 
static ON_UUID PhysicallyBasedUserdataId (void)
 Internal use only. More...
 
- Static Public Member Functions inherited from ON_ModelComponent
static int CompareId (const ON_ModelComponent &a, const ON_ModelComponent &b)
 
static int CompareIdAndName (const ON_ModelComponent &a, const ON_ModelComponent &b)
 
static int CompareName (const ON_ModelComponent &a, const ON_ModelComponent &b)
 
static int CompareNameAndId (const ON_ModelComponent &a, const ON_ModelComponent &b)
 
static int CompareNameExact (const ON_ModelComponent &a, const ON_ModelComponent &b)
 
static ON_ModelComponent::Type ComponentTypeFromUnsigned (unsigned int component_type_as_unsigned)
 
static bool ComponentTypeIsValid (ON_ModelComponent::Type component_type)
 
static bool ComponentTypeIsValidAndNotMixed (ON_ModelComponent::Type component_type)
 
static const ON_wString ComponentTypeToString (ON_ModelComponent::Type)
 
static bool IndexRequired (ON_ModelComponent::Type component_type)
 
static unsigned int Internal_SystemComponentHelper ()
 For internal use. Never call this function. More...
 
static const wchar_tIsNamePathSeparator (const wchar_t *s)
 
*static const wchar_tIsReferencePrefixDelimiter (const wchar_t *s)
 
static const wchar_tIsReferencePrefixSeparator (const wchar_t *s)
 
static bool IsValidComponentName (const class ON_ComponentManifest &model_manfest, const ON_ModelComponent &model_component, bool bPermitReferencePrefix, ON_wString &valid_name)
 
static bool IsValidComponentName (const ON_wString &candidate_component_name)
 
static bool IsValidComponentName (const wchar_t *candidate_component_name)
 
static bool IsValidComponentName (size_t length, const wchar_t *candidate_component_name)
 
static bool IsValidComponentNameFirstCodePoint (int length, const wchar_t *candidate_component_name)
 
static bool IsValidComponentNameFirstCodePoint (ON__UINT32 unicode_code_point)
 
static const ON_wString NameLeaf (const wchar_t *name)
 
static const ON_wString NameParent (const wchar_t *name, bool bIncludeReference)
 
static const ON_wString NameReferencePrefix (const wchar_t *name)
 
static ON__UINT64 NextRuntimeSerialNumber ()
 
static const ON_wString RemoveAllReferencePrefixDelimiters (const wchar_t *name)
 
static const ON_wString RemoveReferencePrefix (const wchar_t *name)
 
static const ON_wString RemoveTrailingNamePathSeparator (const wchar_t *name)
 
static const ON_wString RemoveTrailingReferencePrefixDelimiter (const wchar_t *name)
 
static const ON_wString RemoveTrailingReferencePrefixSeparator (const wchar_t *name)
 
static void SplitName (const wchar_t *name, ON_wString &reference_prefix, ON_wString &name_parent, ON_wString &name_leaf)
 
static bool UniqueNameIgnoresCase (ON_ModelComponent::Type component_type)
 
static bool UniqueNameIncludesParent (ON_ModelComponent::Type component_type)
 
static bool UniqueNameRequired (ON_ModelComponent::Type component_type)
 
- Static Public Attributes inherited from ON_Material
static const ON_Material Default
 index = -1, persistent id More...
 
static const ON_Material DefaultLockedObject
 Default material for locked objects. More...
 
static const double MaxShine
 maximum value of shine exponent = 255.0 More...
 
static const ON_Material Unset
 nil id More...
 
- Static Public Attributes inherited from ON_ModelComponent
static const ON_wString NamePathSeparator
 
static const ON_wString ReferencePrefixDelimiter
 
static const ON_wString ReferencePrefixSeparator
 
static const ON_ModelComponent Unset
 
*static const ON_wString WorksessionReferencePrefix *const wchar_t
 
- Protected Member Functions inherited from ON_ModelComponent
void IncrementContentVersionNumber () const
 

Detailed Description

Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.

THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.

For complete Rhino SDK copyright information see http://www.rhino3d.com/developer.

Constructor & Destructor Documentation

◆ CDisplayAttributeMaterial() [1/3]

CDisplayAttributeMaterial::CDisplayAttributeMaterial ( )

◆ CDisplayAttributeMaterial() [2/3]

CDisplayAttributeMaterial::CDisplayAttributeMaterial ( const ON_Material )

◆ CDisplayAttributeMaterial() [3/3]

CDisplayAttributeMaterial::CDisplayAttributeMaterial ( const CDisplayAttributeMaterial )

◆ ~CDisplayAttributeMaterial()

CDisplayAttributeMaterial::~CDisplayAttributeMaterial ( )

Member Function Documentation

◆ AppearanceEquals()

bool CDisplayAttributeMaterial::AppearanceEquals ( const CDisplayAttributeMaterial other) const

◆ Default()

void CDisplayAttributeMaterial::Default ( )

◆ DocumentAssoc()

const CRhinoDoc* CDisplayAttributeMaterial::DocumentAssoc ( void  ) const

◆ DocumentAssocRSN()

unsigned int CDisplayAttributeMaterial::DocumentAssocRSN ( void  ) const

◆ EnableMipMap()

void CDisplayAttributeMaterial::EnableMipMap ( bool  bEnable)

◆ IsBakedMaterial()

bool CDisplayAttributeMaterial::IsBakedMaterial ( ) const

◆ IsSelectionMapColor()

bool CDisplayAttributeMaterial::IsSelectionMapColor ( ) const

◆ MipMappingEnabled()

bool CDisplayAttributeMaterial::MipMappingEnabled ( ) const

◆ operator=() [1/2]

CDisplayAttributeMaterial& CDisplayAttributeMaterial::operator= ( const CDisplayAttributeMaterial )

◆ operator=() [2/2]

CDisplayAttributeMaterial& CDisplayAttributeMaterial::operator= ( const ON_Material src)

◆ operator==()

bool CDisplayAttributeMaterial::operator== ( const CDisplayAttributeMaterial ) const

◆ Private() [1/2]

CDisplayAttributeMaterial_Private& CDisplayAttributeMaterial::Private ( )

◆ Private() [2/2]

const CDisplayAttributeMaterial_Private& CDisplayAttributeMaterial::Private ( ) const

◆ SetDocumentAssoc() [1/2]

void CDisplayAttributeMaterial::SetDocumentAssoc ( const CRhinoDoc pDoc)

These perform a similar task to CRhRdkContent::DocumentAssoc - when a material is being rendered in the null document scope (ie - the geometry source is nullptr) these functions are there to let the material know which document they come from for the purposes of looking for files and so on.

◆ SetDocumentAssoc() [2/2]

void CDisplayAttributeMaterial::SetDocumentAssoc ( unsigned int  documentRuntimeSerialNumber)

◆ SetIsBakedMaterial()

void CDisplayAttributeMaterial::SetIsBakedMaterial ( bool  b)

◆ SetIsSelectionMapColor()

void CDisplayAttributeMaterial::SetIsSelectionMapColor ( bool  b)

Friends And Related Function Documentation

◆ CDisplayMaterialMgr

friend class CDisplayMaterialMgr
friend

Member Data Documentation

◆ m_bFlatShaded

bool CDisplayAttributeMaterial::m_bFlatShaded

◆ m_bOverrideObjectColor

bool CDisplayAttributeMaterial::m_bOverrideObjectColor

◆ m_bOverrideObjectReflectivity

bool CDisplayAttributeMaterial::m_bOverrideObjectReflectivity

◆ m_bOverrideObjectTransparency

bool CDisplayAttributeMaterial::m_bOverrideObjectTransparency

◆ m_nBumpUnit

int CDisplayAttributeMaterial::m_nBumpUnit
mutable

◆ m_nEmapUnit

int CDisplayAttributeMaterial::m_nEmapUnit
mutable

◆ m_nLuminosity

int CDisplayAttributeMaterial::m_nLuminosity

◆ m_nShineIntensity

int CDisplayAttributeMaterial::m_nShineIntensity

◆ m_nTextureUnit

ON_SimpleArray<int> CDisplayAttributeMaterial::m_nTextureUnit
mutable

◆ m_nTransUnit

int CDisplayAttributeMaterial::m_nTransUnit
mutable

◆ m_selectShadeHighlight

ON_Color CDisplayAttributeMaterial::m_selectShadeHighlight