|
| CRhinoDimRadial () |
|
| CRhinoDimRadial (const CRhinoDimRadial &src) |
|
| CRhinoDimRadial (const ON_3dmObjectAttributes &atts) |
|
void | Draw (CRhinoDisplayPipeline &dp) const override |
| Draws object based on pipeline display attributes... More...
|
|
void | Draw (CRhinoDisplayPipeline &dp, const CRhinoObjectAttributes attribs) const |
|
void | EnableGrips (bool bGripsOn) override |
|
const ON_DimRadial * | GetDimension () const |
|
ON_wString | OnDoubleClick (const CRhinoDoubleClickContext &context) const override |
|
int | Pick (const CRhinoPickContext &context, CRhinoObjRefArray &picklist) const override |
|
void | SetDimension (const ON_DimRadial *dim) |
|
void | SetDimension (ON_DimRadial *dim) |
|
const wchar_t * | ShortDescription (bool bPlural) const override |
|
bool | SnapTo (const CRhinoSnapContext &snap_context, CRhinoSnapEvent &snap_event) const override |
|
void | UpdateBoundingBox (const CRhinoViewport *vp) override |
| Destroy and remake bounding box. More...
|
|
const ON_TextContent * | UpdateDimensionText (const CRhinoDoc *doc, bool in_page_space) |
|
void | ClearBoundingBox () const |
|
void | ForceTextUpdate () const |
|
bool | IsVisibleInViewport (const CRhinoViewport &vp) const |
|
bool | IsVisibleInViewport (const CRhinoViewport &vp, const ON_Xform &xform) const |
|
bool | IsVisibleInViewport (CRhinoDisplayPipeline &dp) const |
|
ON::object_type | ObjectType () const override |
|
const ON_Plane & | Plane () const |
|
bool | SetPlane (const ON_Plane &plane) |
|
| ~CRhinoAnnotation ()=default |
|
const ON_Annotation * | Annotation () const |
|
ON_Annotation * | AnnotationToModify () |
|
ON::AnnotationType | AnnotationType () const |
|
ON_BoundingBox | BoundingBox () const override |
| CRhinoObject override. More...
|
|
ON_BoundingBox | BoundingBox (const CRhinoViewport *pViewport) const override |
| CRhinoObject override. More...
|
|
virtual ON_BoundingBox | BoundingBox (const CRhinoViewport *vp, const ON_DimStyle *dimstyle) const |
|
bool | ContainsMeasurableTextFields () const |
|
const ON_DimStyle & | GetEffectiveDimensionStyle (const CRhinoDoc *doc) const |
|
bool | GetTightBoundingBox (ON_BoundingBox &tight_bbox, bool bGrowBox, const ON_Xform *xform) const override |
| CRhinoObject override. More...
|
|
bool | GetTightBoundingBoxOld (ON_BoundingBox &tight_bbox, bool bGrowBox, const ON_Xform *xform) const |
|
ON_Plane | InitialObjectFrame (const CRhinoDoc &) const |
|
bool | IsActiveInViewport (const CRhinoViewport &viewport) const override |
|
bool | IsVisibleInViewport (const CRhinoViewport &vp) const |
|
bool | IsVisibleInViewport (const CRhinoViewport &vp, const ON_Xform &xform) const |
|
bool | IsVisibleInViewport (CRhinoDisplayPipeline &dp) const |
|
CRhinoAnnotation * | MatchAnnotationObject (const CRhinoAnnotation &matchto) const |
| Return a new object like this with properties of matchto. More...
|
|
ON::object_type | ObjectType (void) const override |
|
const ON_DimStyle & | ParentDimensionStyle (const CRhinoDoc *doc) const |
|
const ON_UUID | ParentDimensionStyleId () const |
|
const ON_wString | PlainText () const |
|
const ON_Plane & | Plane () const |
|
const ON_wString | RichText () const |
|
const ON_TextContent * | TextContent () const |
|
| CRhinoObject () |
| assigns a new object UUID More...
|
|
| CRhinoObject (const CRhinoObject &) |
| copies source object UUID More...
|
|
| CRhinoObject (const ON_3dmObjectAttributes &) |
|
virtual | ~CRhinoObject () |
|
virtual void | AddToDocNotification () |
|
BOOL32 | AttachAttributeUserData (ON_UserData *pUserData) |
|
bool | AttachGeometryUserData (ON_UserData *pUserData) |
|
CRhinoObjectAttributes & | Attributes () |
|
virtual const CRhinoObjectAttributes & | Attributes () const |
|
virtual void | BeginTransform (CRhinoDoc &doc, bool bDeleteOriginal, bool bAddNewObjectToDoc, bool bAddTransformHistory) |
|
virtual ON_BoundingBox | BoundingBox (const class CRhinoViewport *pViewport) const |
|
unsigned int | BrepReferenceCount () const |
|
class CRhObjectReferenceCounter * | BrepReferenceCounter (void) const |
|
void | BrepReferenceCounter_DestroyRuntimeCache (bool bDelete) const |
|
bool | BrepReferenceCounterExists () const |
|
bool | CopyHistoryOnReplace () const |
|
virtual int | CreateMeshes (ON::mesh_type mesh_type, const ON_MeshParameters &mp, bool bIgnoreCustom=false) |
|
BOOL32 | DeleteAttributeUserData (ON_UUID userdata_uuid) |
|
void | DeleteDynamicTransform () |
|
virtual void | DeleteFromDocNotification () |
|
bool | DeleteGeometryUserData (ON_UUID userdata_uuid) |
|
void | DestroyMeshes (ON::mesh_type mesh_type) |
|
virtual void | DestroyMeshes (ON::mesh_type mesh_type, bool bDeleteMeshes) |
|
void | DestroyRuntimeCache (bool bDelete=true) override |
| virtual ON_Object override More...
|
|
class CRhinoDoc * | Document () const |
|
unsigned int | DocumentRuntimeSerialNumber () const |
|
void | Draw (CRhinoViewport &) const |
|
virtual void | DrawGrips (class CRhinoDisplayPipeline &) const |
|
virtual void | DrawHighlightedSubObjects (class CRhinoDisplayPipeline &) const |
|
virtual void | DrawSubObject (class CRhinoDisplayPipeline &, ON_COMPONENT_INDEX) const |
| Draws wireframe representation of a sub object. More...
|
|
virtual void | DrawV6 (class CRhinoObjectDrawContext *draw_context) const RHINO_NOEXCEPT |
|
virtual CRhinoObject * | DuplicateRhinoObject () const |
|
*enum ANALYSIS_MODE **bool | EnableAnalysisMode (ON_UUID am_id, bool bEnable=true) const |
| new way (not virtual) More...
|
|
virtual bool | EnableCustomGrips (class CRhinoObjectGrips *custom_grips) |
|
virtual void | EndTransform (CRhinoDoc &doc, bool bDeleteOriginal, bool bAddNewObjectToDoc, bool bAddTransformHistory) |
|
const ON_Geometry * | Geometry () const |
| returns a pointer to the object's geometry More...
|
|
ON_UserData * | GetAttributeUserData (ON_UUID userdata_uuid) const |
|
bool | GetDynamicTransform (ON_Xform &dynamic_xform) const |
|
virtual bool | GetFrame (ON_Plane &plane) const |
|
ON_UserData * | GetGeometryUserData (ON_UUID userdata_uuid) const |
|
virtual int | GetGrips (ON_SimpleArray< class CRhinoGripObject * > &grip_list) const |
|
virtual int | GetHighlightedSubObjects (ON_SimpleArray< ON_COMPONENT_INDEX > &component_indices) const |
|
std::vector< std::shared_ptr< const ON_Mesh > > | GetMeshes (ON::mesh_type mesh_type) const |
|
virtual int | GetMeshes (ON::mesh_type mesh_type, ON_SimpleArray< const ON_Mesh * > &meshes) const |
|
void | GetRenderMeshParameters (ON_MeshParameters &mp) const |
|
virtual int | GetSelectedSubObjects (ON_SimpleArray< ON_COMPONENT_INDEX > &component_indices) const |
|
virtual int | GetSubobjectMaterialComponents (ON_SimpleArray< ON_COMPONENT_INDEX > &components_with_subobject_materials) const |
|
virtual int | GetSubObjects (ON_SimpleArray< CRhinoObject * > &subObjects, const class CRhinoViewport *pViewport=NULL) const |
|
virtual int | GetWireframeCurves (ON_SimpleArray< ON_Curve * > &curve_list) const |
|
const class CRhinoGripsEnabler * | GripsEnabler () const |
|
int | GripsOn () const |
|
bool | GripsSelected () const |
|
bool | HasCustomRenderMeshes (ON::mesh_type mt, const ON_Viewport *vp=nullptr, ON__UINT32 *flags=nullptr, const class CRhinoPlugIn *requestingPlugIn=nullptr, const class CDisplayPipelineAttributes *pAttributes=nullptr) const |
| Determine if custom render meshes will be supplied for a particular object. More...
|
|
bool | HasDynamicTransform () const |
|
virtual bool | HasSubobjectMaterials (void) const |
|
bool | Highlight (bool bHighlight=true) const |
|
virtual bool | HighlightRequiresRedraw () const |
|
virtual bool | HighlightSubObject (ON_COMPONENT_INDEX component_index, bool bHighlight=true) const |
|
const CRhinoHistoryRecord * | HistoryRecord () const |
|
const ON_UUID | Id () const |
|
bool | InAnalysisMode () const |
|
bool | InAnalysisMode (const ON_UUID &am_id) const |
| bool AnalysisMode( ANALYSIS_MODE am ) const; ///< old way More...
|
|
ON_Plane | InitialObjectFrame (const CRhinoDoc &) const |
|
const class CRhinoVisualAnalysisMode * | InShadedAnalysisMode () const |
|
unsigned int | IsActiveInDocument () const |
|
virtual bool | IsActiveInViewport (const class CRhinoViewport &) const |
|
virtual bool | IsDeletable () const |
|
bool | IsDeleted () const |
|
virtual bool | IsGroupObject () const |
|
bool | IsHidden () const |
|
int | IsHighlighted (BOOL32 bCheckSubObjects=false) const |
| highlighted state (almost always = IsSelected() except in one or two commands) More...
|
|
bool | IsInstanceDefinitionGeometry () const |
|
int | IsInstanceDefinitionGeometryEx () const |
|
bool | IsLocked () const |
|
int | IsMarked () const |
|
virtual bool | IsMeshable (ON::mesh_type) const |
| Returns true if the object is capable of having a mesh of the specified type. More...
|
|
bool | IsModelObject () const |
|
bool | IsNormal () const |
|
bool | IsPageObject () const |
|
int | IsProxy () const |
|
bool | IsReference () const |
|
bool | IsSelectable (bool bIgnoreSelectionState, bool bIgnoreGripsState, bool bIgnoreLocking, bool bIgnoreVisibility) const |
|
bool | IsSelectable (bool bIgnoreSelectionState=false, bool bIgnoreGripsState=false) const |
|
int | IsSelected (bool bCheckSubObjects=false) const |
|
virtual bool | IsSolid () const |
|
virtual bool | IsSubObjectHighlighted (ON_COMPONENT_INDEX component_index) const |
| true if specified component is highlighted More...
|
|
bool | IsSubObjectSelectable (ON_COMPONENT_INDEX component_index, bool bIgnoreSelectionState=false) const |
|
virtual bool | IsSubObjectSelected (ON_COMPONENT_INDEX component_index) const |
|
bool | IsValid (ON_TextLog *text_log=nullptr) const override |
|
bool | IsVisible () const |
|
unsigned int | LinkedInstanceDefinitionSerialNumber () const |
|
void | Mark (int) |
|
void | MemoryRelocate () override |
| virtual ON_Object override More...
|
|
virtual int | MeshCount (ON::mesh_type mesh_type, const ON_MeshParameters *mp=0) const |
|
virtual const class CDisplayPipelineAttributes * | MeshDisplayAttributes (int mesh_index, const ON_Mesh &mesh, const class CDisplayPipelineAttributes &display_attrs) const |
|
const ON_ModelComponent & | ModelComponent () const |
|
ON_UUID | ModelObjectId () const override |
|
virtual bool | ModifyAttributes (const ON_3dmObjectAttributes &new_attributes, bool bEnableUndo=true, bool bQuiet=false) |
|
const ON_wString | Name () const |
|
ON_Color | ObjectDrawColor (bool bIgnoreObjectState=false) const |
|
ON_Color | ObjectDrawColor (const CRhinoObjectAttributes &attributes, bool bIgnoreObjectState=false) const |
|
ON_Color | ObjectDrawColor (const CRhinoObjectAttributes &attributes, const ON_UUID &viewport_id, bool bIgnoreObjectState) const |
|
ON_Plane | ObjectFrame (const ON_COMPONENT_INDEX &ci, unsigned int objectframe_flags) const |
|
const class CRhinoLayer & | ObjectLayer () const |
|
const class CRhinoLayer * | ObjectLayerPtr () const |
|
const CRhinoLinetype & | ObjectLinetype () const |
|
const CRhinoLinetype * | ObjectLinetypePtr () const |
|
virtual const CRhinoMaterial & | ObjectMaterial () const |
|
virtual const CRhinoMaterial & | ObjectMaterial (const ON_3dmObjectAttributes &attrs) const |
|
virtual const CRhinoMaterial & | ObjectMaterial (const ON_COMPONENT_INDEX &ci, const ON_UUID &plugin_id=RhinoDefaultRendererId(), const ON_3dmObjectAttributes *attrs=NULL) const |
| This is now the preferred version of the function. This should be used to get materials component-wise in all cases. More...
|
|
virtual const CRhinoMaterial & | ObjectMaterial (const ON_UUID &plugin_id) const |
|
virtual const CRhRdkMaterial * | ObjectRdkMaterial (const ON_COMPONENT_INDEX &ci, const ON_UUID &plugin_id=RhinoDefaultRendererId(), const ON_3dmObjectAttributes *attrs=NULL) const |
|
CRhinoObject & | operator= (const CRhinoObject &) |
| copies source object UUID More...
|
|
bool | PerViewportIsVisible (ON_UUID viewport_id) const |
|
virtual bool | PickFilter (const class CRhinoGetObject &, bool) const |
|
virtual void | PreDrawUpdate (CRhinoDisplayPipeline &dp) const |
|
virtual bool | PrepareToWrite (int archive_3dm_version) |
|
virtual bool | PromotePreviewMeshes (ON::mesh_type) |
|
std::shared_ptr< const RhRdk::CustomRenderMeshes::IRenderMeshes > | RenderMeshes (ON::mesh_type mt, bool recursive, const ON_Viewport *vp=nullptr, const class CRhRdkObjectAncestry *ancestry_only_for_by_parent_attributes=nullptr, const CRhinoPlugIn *requestingPlugIn=nullptr, const CDisplayPipelineAttributes *pAttributes=nullptr, std::shared_ptr< const RhRdk::CustomRenderMeshes::IRenderMeshes > optional_initial_primitives=nullptr) const |
| Returns a complete set of custom render meshes (primitives) for the object. Simple version with no need for flags. More...
|
|
std::shared_ptr< const RhRdk::CustomRenderMeshes::IRenderMeshes > | RenderMeshes (ON::mesh_type mt, const ON_Viewport *vp=nullptr, const class CRhRdkObjectAncestry *ancestry_only_for_by_parent_attributes=nullptr, ON__UINT32 *flags=nullptr, const CRhinoPlugIn *requestingPlugIn=nullptr, const CDisplayPipelineAttributes *pAttributes=nullptr, std::shared_ptr< const RhRdk::CustomRenderMeshes::IRenderMeshes > optional_initial_primitives=nullptr) const |
| Returns a complete set of custom render meshes (primitives) for the object. More...
|
|
unsigned int | RuntimeSerialNumber () const |
|
int | Select (bool bSelect, bool bSynchHighlight, bool bPersistentSelect, bool bIgnoreGripsState, bool bIgnoreLayerLocking, bool bIgnoreLayerVisibility) const |
|
int | Select (bool bSelect=true, bool bSynchHighlight=true, bool bPersistentSelect=true, bool bIgnoreGripsState=false) const |
|
virtual int | SelectSubObject (ON_COMPONENT_INDEX component_index, bool bSelect=true, bool bSynchHighlight=true, bool bPersistentSelect=false) const |
|
bool | SetCachedTextureCoordinates (const ON_TextureMapping &mapping, const ON_Xform *object_xform, bool bLazy=true) const |
|
bool | SetCachedTextureCoordinatesFromPlugIn (const ON_UUID &plugin_id) const |
|
bool | SetCachedTextureCoordinatesFromPlugIn (const ON_UUID &plugin_id, const ON_SimpleArray< ON_TextureMapping::TYPE > &mappings_to_cache) const |
|
void | SetCopyHistoryOnReplace (bool bCopy) const |
|
bool | SetDynamicTransform (const ON_Xform &dynamic_xform) |
|
bool | SetHistory (class CRhinoHistory &history) |
|
void | SetObjectFrame (const ON_COMPONENT_INDEX &ci, const ON_Plane &plane) |
|
void | SetObjectFrame (const ON_COMPONENT_INDEX &ci, const ON_Xform &wcs_to_ocs) |
|
virtual bool | SetRenderMeshParameters (const ON_MeshParameters &mp) |
|
virtual bool | SetTextureCoordinates (const ON_TextureMapping &mapping, const ON_Xform *object_xform, bool bLazy=true) const |
|
virtual bool | SetTextureCoordinatesFromPlugIn (const ON_UUID &plugin_id, int mapping_channel_id) const |
|
virtual unsigned int | SizeOf () const override |
| returns number of bytes used by this particular instance More...
|
|
ON::active_space | Space () const |
|
virtual ON_ComponentStatus | SubObjectStatus () const |
|
virtual bool | SupportsBrepProxyReferenceCounting () const |
|
bool | UndoModifyAttributes (unsigned int ur_sn=0) |
|
virtual int | UnhighlightAllSubObjects () |
| returns number of changed subobjects More...
|
|
virtual int | UnselectAllSubObjects () |
| returns number of unselected subobjects More...
|
|
void | UpdateBoundingBox () |
|
virtual bool | VetoTransformObject (CRhinoDoc &doc, bool bDeleteOriginal, bool bAddNewObjectToDoc, bool bAddTransformHistory) const |
|
unsigned int | WorksessionReferenceModelSerialNumber () const |
|
| ON_Object () ON_NOEXCEPT |
|
| ON_Object (const ON_Object &) |
|
virtual | ~ON_Object () |
|
virtual ON_AggregateComponentStatus | AggregateComponentStatus () const |
|
bool | AttachUserData (class ON_UserData *pUserData) |
|
unsigned int | ClearAllComponentStates () const |
|
virtual unsigned int | ClearComponentStates (ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_clear) const |
|
virtual unsigned int | ClearComponentStates (ON_ComponentStatus states_to_clear) const |
|
void | CopyUserData (const ON_Object &source_object) |
|
unsigned int | CopyUserData (const ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution) |
|
virtual ON__UINT32 | DataCRC (ON__UINT32 current_remainder) const |
|
virtual bool | DeleteComponents (const ON_COMPONENT_INDEX *ci_list, size_t ci_count) |
|
bool | DetachUserData (class ON_UserData *pUserData) |
|
virtual void | Dump (ON_TextLog &) const |
|
void | EmergencyDestroy () |
|
class ON_UserData * | FirstUserData () const |
|
virtual unsigned int | GetComponentsWithSetStates (ON_ComponentStatus states_filter, bool bAllEqualStates, ON_SimpleArray< ON_COMPONENT_INDEX > &components) const |
|
class ON_UserData * | GetUserData (const ON_UUID &userdata_uuid) const |
|
bool | GetUserString (const wchar_t *key, ON_wString &string_value) const |
|
int | GetUserStringKeys (ON_ClassArray< ON_wString > &user_string_keys) const |
|
int | GetUserStrings (ON_ClassArray< ON_UserString > &user_strings) const |
|
bool | IsCorrupt (bool bRepair, bool bSilentError, class ON_TextLog *text_log) const |
|
bool | IsKindOf (const ON_ClassId *pClassId) const |
|
virtual void | MarkAggregateComponentStatusAsNotCurrent () const |
|
void | MoveUserData (ON_Object &source_object) |
|
unsigned int | MoveUserData (ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution, bool bDeleteAllSourceItems) |
|
ON_Object & | operator= (const ON_Object &) |
|
void | PurgeUserData () |
|
virtual bool | Read (ON_BinaryArchive &binary_archive) |
|
virtual unsigned int | SetComponentStates (ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_set) const |
|
virtual unsigned int | SetComponentStatus (ON_COMPONENT_INDEX component_index, ON_ComponentStatus status_to_copy) const |
|
bool | SetUserString (const wchar_t *key, const wchar_t *string_value) |
|
int | SetUserStrings (int count, const ON_UserString *user_strings, bool bReplace) |
|
bool | ThisIsNullptr (bool bSilentError) const |
|
void | TransformUserData (const class ON_Xform &xform) |
|
virtual bool | UpdateReferencedComponents (const class ON_ComponentManifest &source_manifest, const class ON_ComponentManifest &destination_manifest, const class ON_ManifestMap &manifest_map) |
|
int | UserStringCount () const |
|
virtual bool | Write (ON_BinaryArchive &binary_archive) const |
|