Rhino C++ API
8.13
|
#include <RhinoSdkUiOptionsListCtrlItem.h>
Public Member Functions | |
CRhinoUiOptionsListCtrlEditBox (LPCTSTR lpsLabel=NULL, LPCTSTR lpsText=NULL, int iIndentLevel=0) | |
virtual | ~CRhinoUiOptionsListCtrlEditBox () |
bool | BeginEditItem (CRhinoUiOptionsListCtrl &list_ctrl, const CRect rEdit, begin_edit_item_reason eir) |
void | MoveItemWindow (CRhinoUiOptionsListCtrl &list_ctrl, const CRect rEdit) |
void | OnDrawItem (CDC &dc, const CRect &rItem, const CRect &rDeflate) const |
afx_msg void | OnEnChange () |
virtual bool | OnEndEdit (LPCTSTR lps) const |
afx_msg void | OnEnKillfocus () |
afx_msg BOOL32 | OnEraseBkgnd (CDC *pDC) |
afx_msg BOOL32 | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt) |
virtual BOOL32 | PreTranslateMessage (MSG *pMsg) |
void | SetNumber (double d) |
void | SetNumber (int i) |
void | SetText (LPCTSTR lps) |
virtual LRESULT | WindowProc (UINT message, WPARAM wParam, LPARAM lParam) |
Public Member Functions inherited from CRhinoUiEdit | |
CRhinoUiEdit () | |
virtual | ~CRhinoUiEdit () |
void | DDX_Text (CDataExchange *pDX, int nIDC, double &nValue) |
void | DDX_Text (CDataExchange *pDX, int nIDC, int &nValue) |
void | DDX_Text (CDataExchange *pDX, int nIDC, ON_wString &wValue) |
int | DisplayPrecision () const |
void | Format () |
const CString & | FormatKeyword () const |
int | GetEditType () const |
void | GetNumericValue (double &d) |
void | GetNumericValue (int &n) |
CSpinButtonCtrl * | GetSpinButtonCtrl () const |
void | GetStringValue (ON_wString &w) |
bool | IncludeSpinner () const |
void | LinkToSliderCtrl (CRhinoUiSliderCtrl *) |
afx_msg void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags) |
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct) |
afx_msg void | OnDestroy () |
afx_msg void | OnKillFocus (CWnd *pNewWnd) |
on_number_error | OnNumberErrorMode () const |
afx_msg void | OnSetFocus (CWnd *pOldWnd) |
afx_msg void | OnSize (UINT nType, int cx, int cy) |
void | SetAllowEmpty (bool bSet=true) |
void | SetDisplayPrecision (int precision) |
int | SetEditType (edit_type et) |
void | SetFormatKeyword (const char *lps) |
void | SetFormatKeyword (const wchar_t *lps) |
bool | SetIncludeSpinner (bool b) |
void | SetMax (bool bSet, double nMax=0.0) |
void | SetMax (bool bSet, int nMax=0) |
void | SetMin (bool bSet, double nMin=0.0) |
void | SetMin (bool bSet, int nMin=0) |
void | SetNonZero (bool bSet=TRUE) |
void | SetNumber (double d) |
void | SetNumber (int i) |
void | SetOnNumberErrorMode (on_number_error mode) |
void | SetStringValue (const char *s, bool bAppend=false) |
void | SetStringValue (const wchar_t *w, bool bAppend=false) |
void | SetValue (double nValue) |
void | SetValue (int nValue) |
ON_wString | StringValue () |
void | SynchSlider () |
void | VerifyValue (double &nValue) |
void | VerifyValue (int &nValue) |
Public Member Functions inherited from CRhinoUiOptionsListCtrlItem | |
CRhinoUiOptionsListCtrlItem (const CRhinoUiOptionsListCtrlItem &) | |
CRhinoUiOptionsListCtrlItem (control_type ct=ct_invalid, LPCTSTR lpsLabel=NULL, LPCTSTR lpsText=NULL, int iIndentLevel=0) | |
virtual | ~CRhinoUiOptionsListCtrlItem () |
bool | AutoDelete () const |
control_type | ControlType () const |
void | DrawItemText (CDC &dc, const CString &s, const CRect &rItem, const CRect &rDeflate) const |
bool | GetItemProperty (item_property iprop) const |
bool | GetItemState (item_state istate) const |
CRhinoUiOptionsListCtrl * | GetListCtrl () const |
int | IndentLevel () const |
bool | IsEnabled () const |
bool | IsFullRowItem () const |
bool | IsItemExpandable () const |
bool | IsItemHidden () const |
bool | IsReadOnly () const |
virtual int | ItemHeight () const |
unsigned int | ItemID () const |
LPCTSTR | Label () const |
COLORREF | LabelBackGroundColor () const |
COLORREF | LabelTextColor () const |
const CRhinoUiOptionsListCtrlItem & | operator= (const CRhinoUiOptionsListCtrlItem &) |
int | ParentIndex () const |
bool | SetAutoDelete (bool b) |
int | SetIndentLevel (int iIndentLevel) |
bool | SetIsEnabled (bool b) |
bool | SetIsFullRowItem (bool b) |
bool | SetIsReadOnly (bool b) |
bool | SetItemProperty (item_property iprop, bool bEnabled) |
bool | SetItemState (item_state istate, bool bEnabled) |
bool | SetLabel (LPCTSTR lpsLabel) |
COLORREF | SetLabelBackGroundColor (COLORREF cr) |
COLORREF | SetLabelTextColor (COLORREF cr) |
bool | SetParentIndex (int iItem) |
bool | SetUseLabelColors (bool b) |
virtual LPCTSTR | Text () const |
bool | UseLabelColors () const |
Protected Attributes | |
bool | m_bCancel |
int | m_edit_state = 0 |
Protected Attributes inherited from CRhinoUiEdit | |
bool | m_allowemtpy |
int | m_displayprecision |
int | m_edit_type |
bool | m_hasmax |
bool | m_hasmin |
bool | m_include_buddy |
CString | m_key_word |
CString | m_last_good_string |
double | m_lastgoodnumber |
CRhinoUiSliderCtrl * | m_linked_slider |
double | m_max |
double | m_min |
bool | m_nonzero |
on_number_error | m_on_number_error |
Protected Attributes inherited from CRhinoUiOptionsListCtrlItem | |
CPoint | m_ptEndTrackSelect |
CRhinoUiOptionsListCtrlEditBox
Description: Edit box control. This control can be used to edit string, double or integer values.
CRhinoUiOptionsListCtrlEditBox::CRhinoUiOptionsListCtrlEditBox | ( | LPCTSTR | lpsLabel = NULL , |
LPCTSTR | lpsText = NULL , |
||
int | iIndentLevel = 0 |
||
) |
Description: Constructor
Parameters: lpsLabel [in] Label for this item, appears in left column of options list lpsText [in] Text associated with this item, appears in right column of options list
See Also: CRhinoUiOptionsListCtrlItem constructor
|
virtual |
Description: Destructor
|
virtual |
Description: CRhinoUiOptionsListCtrlItem virtual override
Create CRhinoUiEdit control for editing the Text() value associated with this item.
Parameters: See CRhinoUiOptionsListCtrlItem::BeginEditItem()
Returns: Returns true if edit control was created; otherwise false.
See Also: CRhinoUiOptionsListCtrlItem::BeginEditItem()
Implements CRhinoUiOptionsListCtrlItem.
Reimplemented in CRhinoUiOptionsListCtrlFileNameEditBox.
|
virtual |
Description: CRhinoUiOptionsListCtrlItem virtual override
See CRhinoUiOptionsListCtrlItem::MoveItemWindow() Parameters: See CRhinoUiOptionsListCtrlItem::MoveItemWindow()
See Also: CRhinoUiOptionsListCtrlItem::MoveItemWindow()
Implements CRhinoUiOptionsListCtrlItem.
|
virtual |
Description: CRhinoUiOptionsListCtrlItem override
Reimplemented from CRhinoUiOptionsListCtrlItem.
Reimplemented in CRhinoUiOptionsListCtrlFileNameEditBox.
afx_msg void CRhinoUiOptionsListCtrlEditBox::OnEnChange | ( | ) |
|
virtual |
Description: This method is called when this edit control looses focus to validate the new control value prior to saving.
Parameters: lps [in] New text value
Returns: Returns true if lps is valid and should be saved; otherwise false.
afx_msg void CRhinoUiOptionsListCtrlEditBox::OnEnKillfocus | ( | ) |
afx_msg BOOL32 CRhinoUiOptionsListCtrlEditBox::OnEraseBkgnd | ( | CDC * | pDC | ) |
afx_msg BOOL32 CRhinoUiOptionsListCtrlEditBox::OnMouseWheel | ( | UINT | nFlags, |
short | zDelta, | ||
CPoint | pt | ||
) |
|
virtual |
void CRhinoUiOptionsListCtrlEditBox::SetNumber | ( | double | d | ) |
Description: Convert double to string and put string in edit control.
Parameters: d [in] Value to place in edit control
void CRhinoUiOptionsListCtrlEditBox::SetNumber | ( | int | i | ) |
Description: Convert int to string and put string in edit control.
Parameters: i [in] Value to place in edit control
|
virtual |
Description: CRhinoUiOptionsListCtrlItem override
Reimplemented from CRhinoUiOptionsListCtrlItem.
Reimplemented in CRhinoUiOptionsListCtrlFileNameEditBox.
|
virtual |
|
protected |
|
mutableprotected |