Rhino C++ API
8.13
|
#include <IRhRdkPreviewSceneServer.h>
Classes | |
class | IObjectEx |
Public Member Functions | |
virtual ON_Light * | AddLight (const ON_Light &light)=0 |
virtual IObject * | AddObject (eGeometry geom, const CRhRdkMaterial &m, bool bCopy)=0 |
virtual class CRhRdkLinearWorkflowEx & | GetLinearWorkflow (void)=0 |
virtual bool | OwnsEnvironment (void) const =0 |
virtual bool | OwnsMaterial (void) const =0 |
virtual void | SetEnvironment (const CRhRdkEnvironment *pEnv, bool bCopy, const UUID &uuidRdkDocMat=ON_nil_uuid)=0 |
virtual void | SetSkylighting (bool b)=0 |
virtual void | SetView (const ON_Viewport &view)=0 |
Public Member Functions inherited from IRhRdkPreviewSceneServer | |
virtual | ~IRhRdkPreviewSceneServer () |
virtual void | ApplyRotation (double dRotationX, double dRotationY, eRotationType type)=0 |
virtual ICancellation * | CancellationToken () const =0 |
virtual CRhRdkContent::Kinds | ContentKind (void) const =0 |
virtual const UUID & | ContentPluginId (void) const =0 |
virtual const UUID & | ContentType (void) const =0 |
virtual const CRhRdkEnvironment * | Environment (void) const =0 |
virtual void * | EVF (const wchar_t *, void *)=0 |
virtual bool | GetView (ON_Viewport &view) const =0 |
virtual int | LightCount (void) const =0 |
virtual const IRhRdkLinearWorkflow & | LinearWorkflow (void) const =0 |
RDK_DEPRECATED const class CRhRdkLinearWorkflow & | LinearWorkfow (void) const |
virtual const ON_Light * | NextLight (void) const =0 |
virtual const IObject * | NextObject (void) const =0 |
virtual int | ObjectCount (void) const =0 |
virtual void | ResetLightEnumerator (void) const =0 |
virtual void | ResetObjectEnumerator (void) const =0 |
virtual void | SetCacheImage (const CRhinoDib &image, const UUID &uuidRenderEngine) const =0 |
virtual void | SetCancellationToken (ICancellation *)=0 |
virtual void | SetSceneScale (double dScale)=0 |
virtual DWORD | Signature (void) const =0 |
virtual bool | Skylighting (void) const =0 |
Additional Inherited Members | |
Public Types inherited from IRhRdkPreviewSceneServer | |
enum | eGeometry { geomSphere = 0, geomCuboid = 1, geomCone = 2, geomPyramid = 3, geomTorus = 4, geomPlane = 5, geomSelectedObjects = 6, geomMesh = 7, geomForce32bit = 0xFFFFFFFF } |
enum | eRotationType { camera, object, unset } |
Add a light to the scene.
light | is the light to add – this is copied into a collection. |
|
pure virtual |
Add an object to the scene.
geom | is the geometry to add. |
m | is the material to use for the object. |
bCopy | determines if the material should be copied. |
|
pure virtual |
Get the linear workflow; used for setting its parameters.
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
Set skylighting on or off.
|
pure virtual |
Set the view to use in the preview.