Rhino C++ API  8.6
Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
IRhRdkRenderSettingsSection Class Referenceabstract

#include <IRhRdkSectionHolder.h>

Public Member Functions

virtual const class IRhRdkCurrentEnvironmentCurrentEnvironment (void) const =0
 
virtual const class IRhRdkDitheringDithering (void) const =0
 
virtual void * EVF (const wchar_t *wszFunc, void *pvData)=0
 
virtual const class IRhRdkGroundPlaneGroundPlane (void) const =0
 
virtual const class IRhRdkLinearWorkflowLinearWorkflow (void) const =0
 
virtual const class IRhRdkRhinoSettings * RhinoSettings (void) const =0
 
virtual const class IRhRdkSkylightSkylight (void) const =0
 
virtual const class IRhRdkSunSun (void) const =0
 

Static Public Member Functions

static const IRhRdkCurrentEnvironmentCurrentEnvironment (const IRhinoUiWithController &ui)
 
static const IRhRdkDitheringDithering (const IRhinoUiWithController &ui)
 
static const IRhRdkGroundPlaneGroundPlane (const IRhinoUiWithController &ui)
 
static const IRhRdkLinearWorkflowLinearWorkflow (const IRhinoUiWithController &ui)
 
static const IRhRdkRhinoSettings * RhinoSettings (const IRhinoUiWithController &ui)
 
static const IRhRdkSkylightSkylight (const IRhinoUiWithController &ui)
 
static const IRhRdkSunSun (const IRhinoUiWithController &ui)
 

Protected Member Functions

virtual ~IRhRdkRenderSettingsSection ()
 

Constructor & Destructor Documentation

◆ ~IRhRdkRenderSettingsSection()

virtual IRhRdkRenderSettingsSection::~IRhRdkRenderSettingsSection ( )
inlineprotectedvirtual

Member Function Documentation

◆ CurrentEnvironment() [1/2]

static const IRhRdkCurrentEnvironment* IRhRdkRenderSettingsSection::CurrentEnvironment ( const IRhinoUiWithController ui)
static

◆ CurrentEnvironment() [2/2]

virtual const class IRhRdkCurrentEnvironment* IRhRdkRenderSettingsSection::CurrentEnvironment ( void  ) const
pure virtual

Get the current environment settings.

◆ Dithering() [1/2]

static const IRhRdkDithering* IRhRdkRenderSettingsSection::Dithering ( const IRhinoUiWithController ui)
static

◆ Dithering() [2/2]

virtual const class IRhRdkDithering* IRhRdkRenderSettingsSection::Dithering ( void  ) const
pure virtual

Get the dithering settings.

◆ EVF()

virtual void* IRhRdkRenderSettingsSection::EVF ( const wchar_t *  wszFunc,
void *  pvData 
)
pure virtual

Emergency virtual function for future expansion.

◆ GroundPlane() [1/2]

static const IRhRdkGroundPlane* IRhRdkRenderSettingsSection::GroundPlane ( const IRhinoUiWithController ui)
static

◆ GroundPlane() [2/2]

virtual const class IRhRdkGroundPlane* IRhRdkRenderSettingsSection::GroundPlane ( void  ) const
pure virtual

Get the ground plane settings.

◆ LinearWorkflow() [1/2]

static const IRhRdkLinearWorkflow* IRhRdkRenderSettingsSection::LinearWorkflow ( const IRhinoUiWithController ui)
static

◆ LinearWorkflow() [2/2]

virtual const class IRhRdkLinearWorkflow* IRhRdkRenderSettingsSection::LinearWorkflow ( void  ) const
pure virtual

Get the linear workflow settings.

◆ RhinoSettings() [1/2]

static const IRhRdkRhinoSettings* IRhRdkRenderSettingsSection::RhinoSettings ( const IRhinoUiWithController ui)
static

◆ RhinoSettings() [2/2]

virtual const class IRhRdkRhinoSettings* IRhRdkRenderSettingsSection::RhinoSettings ( void  ) const
pure virtual

Get the Rhino settings.

◆ Skylight() [1/2]

static const IRhRdkSkylight* IRhRdkRenderSettingsSection::Skylight ( const IRhinoUiWithController ui)
static

◆ Skylight() [2/2]

virtual const class IRhRdkSkylight* IRhRdkRenderSettingsSection::Skylight ( void  ) const
pure virtual

Get the skylight settings.

◆ Sun() [1/2]

static const IRhRdkSun* IRhRdkRenderSettingsSection::Sun ( const IRhinoUiWithController ui)
static

◆ Sun() [2/2]

virtual const class IRhRdkSun* IRhRdkRenderSettingsSection::Sun ( void  ) const
pure virtual

Get the sun settings.