Click or drag to resize

GH_ComponentAttributesLayoutComponentBox Method

Utility layout method for GH_Component style UI.

Namespace:  Grasshopper.Kernel.Attributes
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static RectangleF LayoutComponentBox(
	IGH_Component owner
)

Parameters

owner
Type: Grasshopper.KernelIGH_Component
Component to layout.

Return Value

Type: RectangleF
The rectangle describing the box of the component name/icon.
See Also