Click or drag to resize

GH_ComponentAttributesRenderComponentParameters Method

Utility method for rendering all component parameters.

Namespace:  Grasshopper.Kernel.Attributes
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void RenderComponentParameters(
	GH_Canvas canvas,
	Graphics graphics,
	IGH_Component owner,
	GH_PaletteStyle style
)

Parameters

canvas
Type: Grasshopper.GUI.CanvasGH_Canvas
Canvas to draw to.
graphics
Type: System.DrawingGraphics
Graphics to draw with.
owner
Type: Grasshopper.KernelIGH_Component
Component to draw parameters for.
style
Type: Grasshopper.GUI.CanvasGH_PaletteStyle
Component capsule palette style.
See Also