Click or drag to resize

GH_IndexRangeIntersection Method

Create the intersection between two ranges.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GH_IndexRange Intersection(
	GH_IndexRange range0,
	GH_IndexRange range1
)

Parameters

range0
Type: Grasshopper.Kernel.DataGH_IndexRange
First range to intersect.
range1
Type: Grasshopper.Kernel.DataGH_IndexRange
Second range to intersect.

Return Value

Type: GH_IndexRange
The intersection or an invalid range if the input doesn't intersect.
See Also