Click or drag to resize

GH_IndexRangeSplit Method

Split a range into two using an integer index.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static int Split(
	GH_IndexRange range,
	GH_IndexRange splitter,
	out GH_IndexRange result0,
	out GH_IndexRange result1
)

Parameters

range
Type: Grasshopper.Kernel.DataGH_IndexRange
Range to split.
splitter
Type: Grasshopper.Kernel.DataGH_IndexRange
Range to split with.
result0
Type: Grasshopper.Kernel.DataGH_IndexRange
First split result if successful, or an invalid range if not.
result1
Type: Grasshopper.Kernel.DataGH_IndexRange
Second split result if successful, or an invalid range if not.

Return Value

Type: Int32
The number of valid split results.
See Also