Click or drag to resize

GH_IndexRange Methods

The GH_IndexRange type exposes the following members.

Methods
  NameDescription
Public methodAdjacentTo
Tests whether this range is adjacent to another.
Public methodContains(GH_IndexRange)
Tests whether a specified range is entirely contained within this range.
Public methodContains(Int32)
Tests whether a specified index is defined by this range.
Public methodStatic memberIntersection
Create the intersection between two ranges.
Public methodIntersectsWith
Tests whether certain indices are described by both this and another range.
Public methodStatic memberSplit
Split a range into two using an integer index.
Public methodToString (Overrides ValueTypeToString.)
Public methodStatic memberUnion
Create a range which contains both input ranges.
Top
See Also