Click or drag to resize

IGH_StructurePathIndex Method

Find the indices that delineate the given path domain.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
void PathIndex(
	GH_Path path,
	ref int idx0,
	ref int idx1
)

Parameters

path
Type: Grasshopper.Kernel.DataGH_Path
Path to search for (it need not exist in the structure).
idx0
Type: SystemInt32
The index of the path itself or the first smaller path if the path is not defined.
idx1
Type: SystemInt32
The index of the path itself of the first larger path if the path is not defined.
See Also