Click or drag to resize

IGH_StructureExpandPath Method

Expand a path in this structure by appending an element.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
void ExpandPath(
	GH_Path path,
	int element,
	GH_ExpandMode mode
)

Parameters

path
Type: Grasshopper.Kernel.DataGH_Path
Path to expand, if the path doesn't exist, nothing will happen.
element
Type: SystemInt32
Element to append to the path.
mode
Type: Grasshopper.Kernel.DataGH_ExpandMode
Expansion mode.
See Also