Click or drag to resize

IGH_StructureShortestPathIndex Method

Finds the path in this structure with the least dimensions. In case of multiple equally long longest paths, the first one will be returned.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
int ShortestPathIndex()

Return Value

Type: Int32
The index of the shortest path or -1 if there are no paths.
See Also