Click or drag to resize

IGH_DataAccessBlitDataQ Method

Creates a direct copy of an existing data structure. The existing generic instance must of the exact same type as the target parameter.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
bool BlitData<Q>(
	int paramIndex,
	GH_Structure<Q> tree,
	bool overwrite
)
where Q : IGH_Goo

Parameters

paramIndex
Type: SystemInt32
Index of output parameter.
tree
Type: Grasshopper.Kernel.DataGH_StructureQ
Parameter whose data to blit
overwrite
Type: SystemBoolean
If true, any existing data will be removed.

Type Parameters

Q
Type specified for GH_Structure(Of Q) comparison.

Return Value

Type: Boolean
See Also