Click or drag to resize

GH_ParamT Properties

The GH_ParamT generic type exposes the following members.

Properties
  NameDescription
Public propertyAccess
Gets or sets the Access level for this parameter.
Public propertyDataMapping
Gets or sets the data mapping of this Parameter.
Public propertyDataType
Type is either Void if there are no sources or Remote. Derived classes should expand on this.
Public propertyHasProxySources
Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public propertyInstanceDescription
Gets the description of this instance. The default description is about the amount and source of the local values.
(Overrides GH_InstanceDescriptionInstanceDescription.)
Public propertyIsDataProvider (Overrides GH_ActiveObjectIsDataProvider.)
Public propertyIsPrincipal
Gets whether this parameter is a principal parameter. Principal parameters are maintained by components and are not part of the IGH_Param interface.
Public propertyKind
Gets the parameter kind. The kind is evaluated lazily and cached.
Public propertyOptional
Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved.
Public propertyProcessorTime (Overrides GH_ActiveObjectProcessorTime.)
Public propertyProxySourceCount
Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public propertyRecipients
Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself.
Public propertyReverse
Gets or sets the data reverse modifier of this parameter.
Public propertyRuntimeMessageLevel
Returns the worst case flag for the current object

If the object contains at least 1 error, the result is Error.

If the object contains at least 1 warning, the result is Warning.

If the object contains at least 1 message, the result is Remark.

If the object contains no errors, no warnings and no messages, the result is Blank.
Public propertySimplify
Gets or sets the simplify modifier for this parameter.
Public propertySourceCount
Gets the number of sources for this parameter.
Public propertySources
Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource() instead.
Public propertyStateTags
Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings.
Public propertyType
Gets the Framework Type descriptor for the stored Data.
Public propertyTypeName
Calls TypeName() on the first instance of T it can find. This is either an item in the volatile list, or a newly constructed instance.
Public propertyVolatileData
Public propertyVolatileDataCount
Public propertyWireDisplay
Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input.
Top
See Also