Click or drag to resize

GH_RuntimeFile Class

Runtime representation of a Grasshopper help file. A GH_RuntimeFile is nothing more than a collection of keywords with associated content. This class does not interpret a file or check its validity, it merely figures out the different content section based on "Keyword:" entries.
Inheritance Hierarchy
SystemObject
  Grasshopper.DocumentationGH_RuntimeFile

Namespace:  Grasshopper.Documentation
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_RuntimeFile

The GH_RuntimeFile type exposes the following members.

Properties
  NameDescription
Public propertyContent
Gets the data associated with a certain key. For every time the key appears in the file, an array of content strings will be returned.
Public propertyKeys
Gets a list of all the keys present in the File.
Public propertyPath
Gets the path of this help file.
Public propertyStatic memberTags
Gets a collection of all the pre-defined keywords. Use IsKeyword(string) if you want to know whether a string equals a keyword. It's both faster and more reliable than comparing against this collection.
Top
Methods
  NameDescription
Public methodContainsKey
Test whether a certain key is present in the File.
Public methodStatic memberIsTag
Tests whether a string is a predefined Grasshopper Help keyword.
Public methodStatic memberIsTagLine
Tests whether a line of text starts with a Grasshopper Help keyword.
Public methodStatic memberParseFile
Parse a file and return the runtime representation of said file.
Top
Fields
  NameDescription
Public fieldStatic memberTagAuthor
String tag used to identify Author fields in documentation source files.
Public fieldStatic memberTagAutoLink
String tag used to signal whether automatic linking to a topic is allowed.
Public fieldStatic memberTagBeginner
String tag used t o identify Beginner Level Help Content in documentation source files.
Public fieldStatic memberTagCategory
String tag used to identify Category fields in documentation source files.
Public fieldStatic memberTagComponent
String tag used to identify Component IDs in documentation source files.
Public fieldStatic memberTagContact
String tag used to identify Author contact details in documentation source files.
Public fieldStatic memberTagDescription
String tag used t o identify Description fields in glossary source files.
Public fieldStatic memberTagErranyms
String tag used to identify Do Not Confuse collections in documentation source files.
Public fieldStatic memberTagExpert
String tag used t o identify Expert Level Help Content in documentation source files.
Public fieldStatic memberTagInclude
String tag used to signal whether inclusion of a topic is allowed.
Public fieldStatic memberTagIntermediate
String tag used t o identify Intermediate Level Help Content in documentation source files.
Public fieldStatic memberTagKeywords
String tag used to identify Keyword collections in documentation source files.
Public fieldStatic memberTagPronunciation
String tag used to identify Pronunciaion Guide fields (IPA) in glossary source files.
Public fieldStatic memberTagRhinoCommand
String tag used to identify Similar Rhino Commands in documentation source files.
Public fieldStatic memberTagSeeAlso
String tag used to identify See Also collections in documentation source files.
Public fieldStatic memberTagSynonyms
String tag used to identify Synonym collections in glossary source files.
Public fieldStatic memberTagTitle
String tag used to identify title fields in documentation source files.
Top
See Also