Click or drag to resize

GH_CanvasDropTargetValidator Class

Utility validator for restricting component creation.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUI.CanvasGH_CanvasValidator
    Grasshopper.GUI.CanvasGH_CanvasDropTargetValidator

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_CanvasDropTargetValidator : GH_CanvasValidator

The GH_CanvasDropTargetValidator type exposes the following members.

Constructors
  NameDescription
Public methodGH_CanvasDropTargetValidator
Initializes a new instance of the GH_CanvasDropTargetValidator class
Top
Properties
  NameDescription
Public propertyDropDelegate
Gets or sets the delegate to be invoked when a component is dropped inside the dropregion.
Public propertyDropID
Gets or sets the ID for the allowed component.
Public propertyDropRegion
Gets or sets the dropregion for this validator. Regions are cloned so you can dispose of the original immedately after assignment.
Public propertyDropText
Gets or sets the text to display.
Top
Methods
  NameDescription
Public methodAddedToCanvas (Overrides GH_CanvasValidatorAddedToCanvas(GH_Canvas).)
Public methodAppliesToDocument (Overrides GH_CanvasValidatorAppliesToDocument(Guid).)
Public methodCanAcceptObject (Overrides GH_CanvasValidatorCanAcceptObject(Guid).)
Public methodCanCreateObject (Overrides GH_CanvasValidatorCanCreateObject(Guid, PointF).)
Public methodCanDeleteObject (Overrides GH_CanvasValidatorCanDeleteObject(IGH_DocumentObject).)
Public methodCanDragObject (Overrides GH_CanvasValidatorCanDragObject(IGH_DocumentObject, PointF).)
Public methodCanShowCanvasMenu (Overrides GH_CanvasValidatorCanShowCanvasMenu(PointF).)
Public methodCanShowComponentSearchBox (Overrides GH_CanvasValidatorCanShowComponentSearchBox(PointF).)
Public methodRemovedFromCanvas (Overrides GH_CanvasValidatorRemovedFromCanvas(GH_Canvas).)
Top
See Also