Click or drag to resize

GH_DocumentEditor Class

The Grasshopper main window.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DocumentEditor : Form

The GH_DocumentEditor type exposes the following members.

Constructors
  NameDescription
Public methodGH_DocumentEditor
Initializes a new instance of the GH_DocumentEditor class
Top
Properties
  NameDescription
Public propertyCollapsed
Gets a value indicating whether or not the form is currently collapsed.
Protected propertyCreateParams (Overrides FormCreateParams.)
Public propertyFormShepard
Gets the form shepard for this window. Register your modeless dialogs with this shepard if you want to be popular.
Top
Methods
  NameDescription
Public methodClearStatusBar
Clear the Grasshopper status-bar.
Public methodCloseForReal
Really, really close the window.
Public methodCollapseForm
Collapses the form into the title bar area.
Public methodDisableUI
Disable all modifier UI.
Protected methodDispose
Releases the unmanaged resources used by the GH_DocumentEditor and optionally releases the managed resources
(Overrides FormDispose(Boolean).)
Public methodEnableUI
Enable all modifier UI.
Public methodExpandForm
Expands the form if it is currenly collapsed.
Public methodFadeIn
Call this method if the prompt switches back to Grasshopper.
Public methodFadeOut
Call this method if the prompt switches to Rhino.
Public methodFixCanvasToolbarState
Enabled/Disables the appropriate buttons depending on whether there is a document loaded on the canvas.
Public methodScriptAccess_CloseAllDocuments
Closes all documents in the Document Queue.
Public methodScriptAccess_CloseDocument
Closes the currently active document and loads the next available document into the canvas. Changes will not be saved.
Public methodScriptAccess_IsDocument
Returns true if there is an active document.
Public methodScriptAccess_IsDocumentModified
Gets the modified flag of the currently loaded document.
Public methodScriptAccess_NewDocument
Creates a new document and loads it into the Canvas.
Public methodScriptAccess_OpenDocument
Displays a command line interface for File Open... then loads that file into the Canvas.
Public methodScriptAccess_OpenDocument(String)
Loads a specific file off the hard disk into the Canvas.
Public methodScriptAccess_SaveDocument
Saves the document currently loaded in the Canvas. If the document hasn't been saved before then a Save... dialog box will be shown.
Public methodScriptAccess_SaveDocumentAs
Saves the currently active document to disk.
Public methodScriptAccess_SaveDocumentAs(String)
Saves the currently active document to disk.
Public methodSetStatusBarEvent
Set a new message on the Grasshopper status bar.
Public methodToggleForm
Collapses the form if it's currently expanded or expands the form if it's currently collapsed.
Protected methodWndProc
WndProc is overridden in order to allow for title-bar double-click (un)folding.
(Overrides FormWndProc(Message).)
Top
Events
  NameDescription
Public eventStatic memberAggregateShortcutMenuItems
This event is raised whenever a GH_DocumentEditor collects all shortcuttable menu items. If you added items to the menu and you want to be able to have custom shortcuts on these items, you must handle this event and insert your own items.
Public eventEditorFoldStateChanged
This event is raised whenever the main windows folds or unfolds.
Top
Extension Methods
See Also