Click or drag to resize

GH_GHXHarvester Class

Provides static methods for harvesting data from GHX and GH files.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_GHXHarvester

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_GHXHarvester
Methods
  NameDescription
Public methodStatic memberHarvestBoundingBoxes(GH_Archive)
Harvest all attribute bounding boxes from a GHX/GH archive.
Public methodStatic memberHarvestBoundingBoxes(GH_IReader)
Harvest all attribute bounding boxes from a GHX/GH node.
Public methodStatic memberHarvestBoundingBoxes(String)
Harvest all attribute bounding boxes from a GHX/GH archive.
Public methodStatic memberHarvestPivots(GH_Archive)
Harvest all attribute pivots from a GHX/GH archive.
Public methodStatic memberHarvestPivots(GH_IReader)
Harvest all attribute pivots from a GHX/GH node.
Public methodStatic memberHarvestPivots(String)
Harvest all attribute pivots from a GHX/GH archive.
Top
See Also