Click or drag to resize

GH_Time Class

Represents a date and time. GH_Time re-implements the framework System.DateTime type.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooDateTime
    Grasshopper.Kernel.TypesGH_Time

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Time : GH_Goo<DateTime>

The GH_Time type exposes the following members.

Constructors
  NameDescription
Public methodGH_Time
Blank constructor
Public methodGH_Time(DateTime)
Initializes a new instance of the GH_Time class
Public methodGH_Time(GH_Time)
Initializes a new instance of the GH_Time class
Top
Properties
  NameDescription
Public propertyIsValid
Gets the validity of this instance. Datetime is valid if it's not equal to DateTime.MaxValue
(Overrides GH_GooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate (Overrides GH_GooTDuplicate.)
Public methodDuplicateDateTime
Public methodEmitProxy (Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also