Description:

Adds a new empty group to the group table.

Syntax:
public int Add()
Returns:
Type: int
>=0 index of new group. -1 group not added because a group with that name already exists.
Remarks:
In some cases, calling Add() can cause the group indices to become invalid.
Available since:
5.0

Description:

Adds a new group to the group table with a set of objects.

Syntax:
public int Add(
IEnumerable<Guid> objectIds
)
Parameters:
  • objectIds
  • Type: System.Collections.Generic.IEnumerable<Guid>
  • An array, a list or any enumerable set of object IDs.
Returns:
Type: int
>=0 index of new group. -1 group not added because a group with that name already exists.
Remarks:
In some cases, calling Add() can cause the group indices to become invalid.
Available since:
5.0

Description:

Adds a new group to the group table with a set of objects.

Syntax:
public int Add(
string groupName,
IEnumerable<Guid> objectIds
)
Parameters:
  • groupName
  • Type: string
  • Name of new group.
  • objectIds
  • Type: System.Collections.Generic.IEnumerable<Guid>
  • An array, a list or any enumerable set of object IDs.
Returns:
Type: int
>=0 index of new group. -1 group not added because a group with that name already exists.
Remarks:
In some cases, calling Add() can cause the group indices to become invalid.
Available since:
5.0

Description:

Adds a new empty group to the group table.

Syntax:
public int Add(
string groupName
)
Parameters:
  • groupName
  • Type: string
  • name of new group.
Returns:
Type: int
>=0 index of new group. -1 group not added because a group with that name already exists.
Remarks:
In some cases, calling Add() can cause the group indices to become invalid.
Available since:
5.0

Nothing found