Description:

Remaps an enumeration of Rhino objects to new groups.

Syntax:
public int RemapObjects(
IEnumerable<RhinoObject> rhinoObjects,
out Dictionary<int, int> indexMap
)
Parameters:
  • rhinoObjects
  • Type: IEnumerable<RhinoObject>
  • The enumeration of Rhino objects.
  • indexMap
  • Type: Dictionary<int, int>
  • A map from old group indices to new group indices.
Returns:
Type: int
The number of Rhino objects that were modified.
Remarks:
In some situations, a bunch of Rhino objects are copied, new groups need to be created. This method handles the details.
Available since:
8.16

Description:

Remaps an enumeration of Rhino objects to new groups.

Syntax:
public int RemapObjects(
IEnumerable<RhinoObject> rhinoObjects
)
Parameters:
  • rhinoObjects
  • Type: IEnumerable<RhinoObject>
  • The enumeration of Rhino objects.
Returns:
Type: int
The number of Rhino objects that were modified.
Remarks:
In some situations, a bunch of Rhino objects are copied, new groups need to be created. This method handles the details.
Available since:
8.16

Nothing found