|
double | DSxArrowSize () const |
|
double | DSxCenterMark () const |
|
double | DSxDimExtension () const |
|
double | DSxExtExtension () const |
|
double | DSxExtOffset () const |
|
double | DSxLeaderArrowSize () const |
|
double | DSxTextGap () const |
|
double | DSxTextHeight () const |
|
bool | IsReference () const |
|
bool | IsSystemDimStyle () const |
|
unsigned int | LinkedInstanceDefinitionSerialNumber () const |
|
bool | operator== (const CRhinoDimStyle &) const |
|
unsigned int | WorksessionReferenceModelSerialNumber () const |
|
| ON_DimStyle () |
| Default constructor result is identical to ON_DimStyle::Unset;. More...
|
|
| ON_DimStyle (const ON_3dmAnnotationSettings &src) |
|
| ON_DimStyle (const ON_DimStyle &src)=default |
|
| ON_DimStyle (ON::LengthUnitSystem model_length_unit_system, const class ON_V5x_DimStyle &src) |
| Used when reading V5 and earlier archives. More...
|
|
| ~ON_DimStyle ()=default |
|
bool | Alternate () const |
| Additional measurement display toggle. More...
|
|
bool | AlternateBelow () const |
|
ON_DimStyle::LengthDisplay | AlternateDimensionLengthDisplay () const |
| Set dimension length units and format /summary> More...
|
|
ON::LengthUnitSystem | AlternateDimensionLengthDisplayUnit (unsigned int model_sn) const |
| Parameters: model_sn - 0, a model serial number, or ON_UNSET_UINT_INDEX to use the dimstyle's ModelSerialNumber() value. Returns Unit system for dimension length display. If DimensionLengthDisplay() == ON_DimStyle::LengthDisplay::ModelUnits and model_sn > 0, then the value of ON::LengthUnitSystemFromModelSerialNumber(model_sn) is returned. If DimensionLengthDisplay() == ON_DimStyle::LengthDisplay::ModelUnits and model_sn == 0, then ON::LengthUnitSystem::None is returned. /summary> More...
|
|
double | AlternateLengthFactor () const |
| AlternateLengthFactor is a rarely used. See Length factor for a description of this property. /summary> More...
|
|
int | AlternateLengthResolution () const |
| Display resolution for alternate length measurements. More...
|
|
const ON_wString & | AlternatePrefix () const |
| Dimension alternate prefix text. More...
|
|
double | AlternateRoundOff () const |
|
const ON_wString & | AlternateSuffix () const |
| Dimension alternate suffix text. More...
|
|
int | AlternateToleranceResolution () const |
|
ON_DimStyle::suppress_zero | AlternateZeroSuppress () const |
|
angle_format | AngleFormat () const |
|
int | AngleResolution () const |
| Display resolution for angle measurements. More...
|
|
double | AngleRoundOff () const |
|
ON_DimStyle::suppress_zero | AngleZeroSuppress () const |
|
int | ArcLengthSymbol () const |
|
ON_UUID | ArrowBlockId1 () const |
|
ON_UUID | ArrowBlockId2 () const |
|
ON_Color | ArrowColor () const |
|
ON::object_color_source | ArrowColorSource () const |
|
ON_DimStyle::arrow_fit | ArrowFit () const |
|
ON_Color | ArrowPlotColor () const |
|
ON::plot_color_source | ArrowPlotColorSource () const |
|
double | ArrowSize () const |
| Arrow size. More...
|
|
ON_Arrowhead::arrow_type | ArrowType1 () const |
|
ON_Arrowhead::arrow_type | ArrowType2 () const |
|
double | BaselineSpacing () const |
|
double | CenterMark () const |
| Centermark size. More...
|
|
ON_DimStyle::centermark_style | CenterMarkStyle () const |
| Centermark style. More...
|
|
void | ClearAllFieldOverrides () |
|
bool | CompareDimstyle (const ON_DimStyle &src) const |
|
bool | CompareFields (const ON_DimStyle &src) const |
|
const class ON_SHA1_Hash & | ContentHash () const |
|
const ON_DimStyle | CreateOverrideCandidate () const |
|
wchar_t | DecimalSeparator () const |
|
ON_DimStyle::LengthDisplay | DimensionLengthDisplay () const |
| Dimension length units and format /summary> More...
|
|
ON::LengthUnitSystem | DimensionLengthDisplayUnit (unsigned int model_sn) const |
| Parameters: model_sn - 0, a model serial number, or ON_UNSET_UINT_INDEX to use the dimstyle's ModelSerialNumber() value. Returns Unit system for dimension length display. If DimensionLengthDisplay() == ON_DimStyle::LengthDisplay::ModelUnits and model_sn > 0, then the value of ON::LengthUnitSystemFromModelSerialNumber(model_sn) is returned. If DimensionLengthDisplay() == ON_DimStyle::LengthDisplay::ModelUnits and model_sn == 0, then ON::LengthUnitSystem::None is returned. /summary> More...
|
|
ON_Color | DimensionLineColor () const |
|
ON::object_color_source | DimensionLineColorSource () const |
|
ON_Color | DimensionLinePlotColor () const |
|
ON::plot_color_source | DimensionLinePlotColorSource () const |
|
double | DimensionLinePlotWeight () const |
|
ON::plot_weight_source | DimensionLinePlotWeightSource () const |
|
double | DimExtension () const |
| Extension of dimension line past extension lines. More...
|
|
ON_DimStyle::ContentAngleStyle | DimRadialTextAngleStyle () const |
|
ON_DimStyle::TextLocation | DimRadialTextLocation () const |
| The location of text relative to the dimension line in radial dimensions. More...
|
|
ON::TextOrientation | DimRadialTextOrientation () const |
|
double | DimScale () const |
|
int | DimScaleSource () const |
| 0: Global DimScale, 1: DimStyle DimScale More...
|
|
ON_DimStyle::ContentAngleStyle | DimTextAngleStyle () const |
|
ON_DimStyle::TextLocation | DimTextLocation () const |
| The location of text relative to the dimension line in linear, angular, and ordinate dimensions. More...
|
|
ON::TextOrientation | DimTextOrientation () const |
|
bool | DrawForward () const |
|
bool | DrawTextMask () const |
| Determines whether or not to draw a Text Mask. More...
|
|
void | Dump (ON_TextLog &) const override |
| virtual More...
|
|
void | EmergencyDestroy () |
| Interface. More...
|
|
ON_Color | ExtensionLineColor () const |
|
ON::object_color_source | ExtensionLineColorSource () const |
|
ON_Color | ExtensionLinePlotColor () const |
|
ON::plot_color_source | ExtensionLinePlotColorSource () const |
|
double | ExtensionLinePlotWeight () const |
|
ON::plot_weight_source | ExtensionLinePlotWeightSource () const |
|
double | ExtExtension () const |
| Extension line extension. More...
|
|
double | ExtOffset () const |
| Extension line offset. More...
|
|
double | FixedExtensionLen () const |
|
bool | FixedExtensionLenOn () const |
|
const class ON_Font & | Font () const |
|
const class ON_Font & | FontCharacteristics () const |
|
const bool | FontSubstituted () const |
|
bool | ForceDimLine () const |
|
bool | HasOverrides () const |
|
void | InheritFields (const ON_DimStyle &parent) |
|
bool | IsChildDimstyle () const |
| Test if this dimstyle is the child of any other dimstyle. More...
|
|
bool | IsChildOf (const ON_UUID &parent_id) const |
|
bool | IsFieldOverride (ON_DimStyle::field field_id) const |
|
bool | IsOverrideDimStyleCandidate (ON_UUID parent_id, bool bRequireSetOverrides, ON_wString *error_description=nullptr) const |
|
bool | IsValid (class ON_TextLog *text_log=nullptr) const override |
| virtual More...
|
|
ON_UUID | LeaderArrowBlockId () const |
|
double | LeaderArrowSize () const |
| Arrow size. More...
|
|
ON_Arrowhead::arrow_type | LeaderArrowType () const |
|
double | LeaderContentAngleDegrees () const |
|
double | LeaderContentAngleRadians () const |
|
ON_DimStyle::ContentAngleStyle | LeaderContentAngleStyle () const |
| was contentalignment More...
|
|
ON_DimStyle::leader_curve_type | LeaderCurveType () const |
|
bool | LeaderHasLanding () const |
|
double | LeaderLandingLength () const |
|
ON::TextHorizontalAlignment | LeaderTextHorizontalAlignment () const |
|
ON::TextOrientation | LeaderTextOrientation () const |
|
ON::TextVerticalAlignment | LeaderTextVerticalAlignment () const |
| was attachstyle More...
|
|
double | LengthFactor () const |
| LengthFactor is a rarely used. It applies when a model is being drawn to a scale and the dimension length values should be reverse scaled. For example, if a model is drawn at 1/4 scale, a line 5 units long indicates the real world line is 20 units long. In this case setting LengthFactor to 4 would cause a linear dimension applied to that line to display a value of 20. /summary> More...
|
|
int | LengthResolution () const |
| Display resolution for distance measurements. More...
|
|
double | MaskBorder () const |
|
ON_Color | MaskColor () const |
|
ON_TextMask::MaskType | MaskFillType () const |
| Determines where to get the color to draw a Text Mask. More...
|
|
ON_TextMask::MaskFrame | MaskFrameType () const |
| Determines whether to draw a frame around a Text Mask. More...
|
|
ON_DimStyle & | operator= (const ON_DimStyle &)=default |
|
ON__UINT32 | OverrideCount () const |
|
void | OverrideFields (const ON_DimStyle &source, const ON_DimStyle &parent) |
|
void | OverrideFieldsWithDifferentValues (const ON_DimStyle &source, const ON_DimStyle &parent) |
|
const ON_SHA1_Hash & | ParentContentHash () const |
|
const class ON_Font & | ParentDimStyleFont () const |
|
const ON_wString & | Prefix () const |
| Dimension prefix text. More...
|
|
bool | Read (ON_BinaryArchive &) override |
| virtual More...
|
|
double | RoundOff () const |
|
void | Scale (double scale) |
|
double | ScaleLeftLength_mm () const |
|
double | ScaleRightLength_mm () const |
|
const ON_ScaleValue & | ScaleValue () const |
|
void | SetAlternate (bool) |
|
void | SetAlternateBelow (bool below) |
|
void | SetAlternateDimensionLengthDisplay (ON_DimStyle::LengthDisplay length_display) |
| Set alternate dimension length units and format /summary> More...
|
|
void | SetAlternateLengthFactor (double) |
| AlternateLengthFactor is a rarely used. See Length factor for a description of this property. /summary> More...
|
|
void | SetAlternateLengthResolution (int) |
|
void | SetAlternatePrefix (const wchar_t *) |
|
void | SetAlternateRoundOff (double r) |
|
void | SetAlternateSuffix (const wchar_t *) |
|
void | SetAlternateToleranceResolution (int r) |
|
void | SetAlternateZeroSuppress (ON_DimStyle::suppress_zero s) |
|
void | SetAngleFormat (angle_format format) |
|
void | SetAngleResolution (int) |
|
void | SetAngleRoundOff (double r) |
|
void | SetAngleZeroSuppress (ON_DimStyle::suppress_zero s) |
|
void | SetArcLengthSymbol (int m) |
|
void | SetArrowBlockId1 (ON_UUID id) |
|
void | SetArrowBlockId2 (ON_UUID id) |
|
void | SetArrowColor (ON_Color c) |
|
void | SetArrowColorSource (const ON::object_color_source src) |
|
void | SetArrowFit (ON_DimStyle::arrow_fit arrowfit) |
|
void | SetArrowPlotColor (ON_Color c) |
|
void | SetArrowPlotColorSource (const ON::plot_color_source src) |
|
void | SetArrowSize (const double) |
|
void | SetArrowType1 (ON_Arrowhead::arrow_type) |
|
void | SetArrowType1And2 (ON_Arrowhead::arrow_type) |
|
void | SetArrowType2 (ON_Arrowhead::arrow_type) |
|
void | SetBaselineSpacing (double spacing) |
|
void | SetCenterMark (const double) |
|
void | SetCenterMarkStyle (ON_DimStyle::centermark_style style) |
|
void | SetDecimalSeparator (wchar_t separator) |
|
void | SetDimensionLengthDisplay (ON_DimStyle::LengthDisplay length_display) |
| Alternate dimension length units and format /summary> More...
|
|
void | SetDimensionLineColor (ON_Color c) |
|
void | SetDimensionLineColorSource (const ON::object_color_source src) |
|
void | SetDimensionLinePlotColor (ON_Color c) |
|
void | SetDimensionLinePlotColorSource (const ON::plot_color_source src) |
|
void | SetDimensionLinePlotWeight (double w) |
|
void | SetDimensionLinePlotWeightSource (const ON::plot_weight_source src) |
|
void | SetDimExtension (const double e) |
|
void | SetDimRadialTextAngleStyle (ON_DimStyle::ContentAngleStyle style) |
|
void | SetDimRadialTextLocation (ON_DimStyle::TextLocation) |
|
void | SetDimRadialTextOrientation (ON::TextOrientation) |
|
void | SetDimScale (double left_val, ON::LengthUnitSystem left_us, double right_val, ON::LengthUnitSystem right_us) |
|
void | SetDimScale (double scale) |
|
void | SetDimScale (ON_ScaleValue sv) |
|
void | SetDimScaleSource (int source) |
|
void | SetDimTextAngleStyle (ON_DimStyle::ContentAngleStyle style) |
|
void | SetDimTextLocation (ON_DimStyle::TextLocation) |
|
void | SetDimTextOrientation (ON::TextOrientation) |
|
void | SetDrawForward (bool drawforward) |
|
void | SetDrawTextMask (bool bDraw) |
|
void | SetExtensionLineColor (ON_Color c) |
|
void | SetExtensionLineColorSource (const ON::object_color_source src) |
|
void | SetExtensionLinePlotColor (ON_Color c) |
|
void | SetExtensionLinePlotColorSource (const ON::plot_color_source src) |
|
void | SetExtensionLinePlotWeight (double w) |
|
void | SetExtensionLinePlotWeightSource (const ON::plot_weight_source src) |
|
void | SetExtExtension (const double) |
|
void | SetExtOffset (const double) |
|
void | SetFieldOverride (ON_DimStyle::field field_id, bool bOverrideParent) |
|
void | SetFieldOverrideAll (bool bOverrideParent) |
|
void | SetFixedExtensionLen (double l) |
|
void | SetFixedExtensionLenOn (bool on) |
|
void | SetFont (const class ON_Font &font_characteristics) |
|
void | SetForceDimLine (bool forcedimline) |
|
void | SetLeaderArrowBlockId (ON_UUID id) |
|
void | SetLeaderArrowSize (const double) |
|
void | SetLeaderArrowType (ON_Arrowhead::arrow_type) |
|
void | SetLeaderContentAngleDegrees (double angle_degrees) |
|
void | SetLeaderContentAngleRadians (double angle_radians) |
|
void | SetLeaderContentAngleStyle (ON_DimStyle::ContentAngleStyle style) |
|
void | SetLeaderCurveType (ON_DimStyle::leader_curve_type type) |
|
void | SetLeaderHasLanding (bool landing) |
|
void | SetLeaderLandingLength (double length) |
|
void | SetLeaderTextHorizontalAlignment (ON::TextHorizontalAlignment halign) |
|
void | SetLeaderTextOrientation (ON::TextOrientation) |
|
void | SetLeaderTextVerticalAlignment (ON::TextVerticalAlignment style) |
|
void | SetLengthFactor (double) |
| LengthFactor is a rarely used. It applies when a model is being drawn to a scale and the dimension length values should be reverse scaled. For example, if a model is drawn at 1/4 scale, a line 5 units long indicates the real world line is 20 units long. In this case setting LengthFactor to 4 would cause a linear dimension applied to that line to display a value of 20. /summary> More...
|
|
void | SetLengthResolution (int) |
|
void | SetMaskBorder (double offset) |
|
void | SetMaskColor (ON_Color color) |
| Does not return viewport background color. More...
|
|
void | SetMaskFillType (ON_TextMask::MaskType source) |
|
void | SetMaskFrameType (ON_TextMask::MaskFrame source) |
|
void | SetPrefix (const wchar_t *) |
|
void | SetRoundOff (double r) |
|
void | SetSignedOrdinate (bool allowsigned) |
|
void | SetSourceDimstyle (ON_UUID source_uuid) |
|
void | SetStackFractionFormat (ON_DimStyle::stack_format f) |
|
void | SetStackHeightScale (double f) |
|
void | SetSuffix (const wchar_t *) |
|
void | SetSuppressArrow1 (bool s) |
|
void | SetSuppressArrow2 (bool s) |
|
void | SetSuppressExtension1 (bool) |
|
void | SetSuppressExtension2 (bool) |
|
void | SetTextColor (ON_Color c) |
|
void | SetTextColorSource (const ON::object_color_source src) |
|
void | SetTextFit (ON_DimStyle::text_fit textfit) |
|
void | SetTextGap (double gap) |
|
void | SetTextHeight (double height) |
|
void | SetTextHorizontalAlignment (ON::TextHorizontalAlignment halign) |
|
void | SetTextMask (const ON_TextMask &text_mask) |
|
void | SetTextMoveLeader (int m) |
|
void | SetTextOrientation (ON::TextOrientation) |
|
void | SetTextPlotColor (ON_Color c) |
|
void | SetTextPlotColorSource (const ON::object_color_source src) |
|
void | SetTextRotation (double r) |
|
void | SetTextUnderlined (bool underlined) |
|
void | SetTextVerticalAlignment (ON::TextVerticalAlignment style) |
|
void | SetToleranceFormat (ON_DimStyle::tolerance_format format) |
|
void | SetToleranceHeightScale (double scale) |
|
void | SetToleranceLowerValue (double lower_value) |
|
void | SetToleranceResolution (int resolution) |
|
void | SetToleranceUpperValue (double upper_value) |
|
void | SetToleranceZeroSuppress (ON_DimStyle::suppress_zero s) |
|
void | SetUnitSystem (ON::LengthUnitSystem us) |
| NOTE WELL: A dimstyle unit system was added in V6, but has never been fully used. The idea was this would make it easier to figure out what text height/ arrow size, ... actually meant. Especially in situations where model space and page space have different unit systems, and in more complex cases like text in instance definitions and inserting annotation from models with mismatched unit systems. It is used internally to get some scales properly set and use in limited merging contexts. More...
|
|
void | SetUnitSystemFromContext (bool bUseName, ON::LengthUnitSystem source_unit_system, ON::LengthUnitSystem destination_unit_system) |
|
void | SetZeroSuppress (ON_DimStyle::suppress_zero s) |
|
bool | SignedOrdinate () const |
|
ON_UUID | SourceDimstyle () const |
|
ON_DimStyle::stack_format | StackFractionFormat () const |
|
double | StackHeightScale () const |
|
const ON_wString & | Suffix () const |
| Dimension suffix text. More...
|
|
bool | SuppressArrow1 () const |
|
bool | SuppressArrow2 () const |
|
bool | SuppressExtension1 () const |
| Suppress first dimension extension line. More...
|
|
bool | SuppressExtension2 () const |
| Suppress second dimension extension line. More...
|
|
double | TextAdvanceOfCodePoint (unsigned unicode_code_point) const |
|
ON_Color | TextColor () const |
|
ON::object_color_source | TextColorSource () const |
|
ON_DimStyle::text_fit | TextFit () const |
|
double | TextGap () const |
| Distance from dimension lines to text. More...
|
|
double | TextHeight () const |
| Height of dimension text. More...
|
|
ON::TextHorizontalAlignment | TextHorizontalAlignment () const |
|
const ON_TextMask & | TextMask () const |
|
int | TextMoveLeader () const |
|
ON::TextOrientation | TextOrientation () const |
|
ON_Color | TextPlotColor () const |
|
ON::object_color_source | TextPlotColorSource () const |
|
const class ON_SHA1_Hash | TextPositionPropertiesHash () const |
|
double | TextRotation () const |
|
bool | TextUnderlined () const |
|
ON::TextVerticalAlignment | TextVerticalAlignment () const |
|
double | TextWidthOfEmSpace () const |
|
double | TextWidthOfEnSpace () const |
|
double | TextWidthOfFigureSpace () const |
|
double | TextWidthOfIdeographicSpace () const |
|
double | TextWidthOfMediumMathematicalSpace () const |
|
double | TextWidthOfSpace () const |
|
tolerance_format | ToleranceFormat () const |
|
double | ToleranceHeightScale () const |
|
double | ToleranceLowerValue () const |
|
int | ToleranceResolution () const |
|
double | ToleranceUpperValue () const |
|
ON_DimStyle::suppress_zero | ToleranceZeroSuppress () const |
|
ON::LengthUnitSystem | UnitSystem () const |
| NOTE WELL: A dimstyle unit system was added in V6, but has never been fully used. The idea was this would make it easier to figure out what text height/ arrow size, ... actually meant. Especially in situations where model space and page space have different unit systems, and in more complex cases like text in instance definitions and inserting annotation from models with mismatched unit systems. It is used internally to get some scales properly set and use in limited merging contexts. More...
|
|
bool | UnitSystemIsSet () const |
|
bool | Write (ON_BinaryArchive &) const override |
| virtual More...
|
|
ON_DimStyle::suppress_zero | ZeroSuppress () const |
|
| ON_ModelComponent () ON_NOEXCEPT |
|
| ON_ModelComponent (const ON_ModelComponent &source) |
|
| ON_ModelComponent (ON_ModelComponent::Type component_type) ON_NOEXCEPT |
|
| ON_ModelComponent (ON_ModelComponent::Type component_type, const ON_ModelComponent &source) ON_NOEXCEPT |
| Locked status of source attributes is not copied to permit copy and modify operations. More...
|
|
| ~ON_ModelComponent ()=default |
|
bool | ChangeName (const wchar_t *new_name, class ON_ComponentManifest *manifest) |
|
bool | ClearComponentType () |
|
bool | ClearId () |
|
bool | ClearIndex () |
|
unsigned int | ClearModelComponentAttributes (unsigned int attributes_filter) |
|
bool | ClearModelComponentStatus () |
|
bool | ClearModelSerialNumber () |
|
bool | ClearName () |
|
bool | ClearParentId () |
|
int | CompareName (const ON_UUID &other_parent_id, const wchar_t *other_name) const |
|
int | CompareName (const wchar_t *other_name) const |
|
int | CompareNameExact (const ON_UUID &other_parent_id, const wchar_t *other_name) const |
|
int | CompareNameExact (const wchar_t *other_name) const |
|
ON_ModelComponent::Type | ComponentType () const |
|
bool | ComponentTypeIsLocked () const |
|
bool | ComponentTypeIsSet () const |
|
ON__UINT64 | ContentVersionNumber () const |
|
unsigned int | CopyFrom (const ON_ModelComponent &src, unsigned int attributes_filter) |
|
ON__UINT32 | DataCRC (ON__UINT32 current_remainder) const override |
|
const ON_wString | DeletedName () const |
|
const ON_NameHash & | DeletedNameHash () const |
|
bool | DeletedNameIsSet () const |
|
bool | DeleteName () |
|
void | Dump (ON_TextLog &) const override |
|
bool | EraseIdentification (bool bIgnoreLocks) |
|
const wchar_t * | GetName (ON_wString &component_name) const |
|
const ON_UUID & | Id () const |
|
bool | IdIsLocked () const |
|
bool | IdIsNil () const |
|
bool | IdIsNotNil () const |
|
bool | IdIsSet () const |
|
const ON_UUID & | IfIdIsNilSetId () |
|
int | Index () const |
|
int | Index (int unset_index_value) const |
|
bool | IndexIsLocked () const |
|
bool | IndexIsSet () const |
|
unsigned int | InstanceDefinitionModelSerialNumber () const |
|
bool | IsDeleted () const |
|
bool | IsHidden () const |
|
bool | IsLocked () const |
|
bool | IsReferenceComponent () const |
|
bool | IsSystemComponent () const |
|
bool | IsValid (class ON_TextLog *text_log=nullptr) const override |
|
void | LockAllSettingsExceptName () |
|
void | LockComponentType () |
|
void | LockId () |
|
void | LockIndex () |
|
void | LockModelComponentStatus () |
|
void | LockModelSerialNumber () |
|
void | LockName () |
|
void | LockParentId () |
|
ON_ComponentStatus | ModelComponentStatus () const |
|
bool | ModelComponentStatusIsLocked () const |
|
bool | ModelComponentStatusIsSet () const |
|
ON_UUID | ModelObjectId () const override |
|
unsigned int | ModelSerialNumber () const |
|
bool | ModelSerialNumberIsLocked () const |
|
bool | ModelSerialNumberIsSet () const |
|
const ON_wString | Name () const |
|
const wchar_t * | NameAsPointer () const |
|
const ON_NameHash & | NameHash () const |
|
bool | NameIsEmpty () const |
|
bool | NameIsLocked () const |
|
bool | NameIsNotEmpty () const |
|
bool | NameIsSet () const |
|
const ON_NameHash | NewNameHash (const wchar_t *new_name) const |
|
ON_ModelComponent & | operator= (const ON_ModelComponent &source) |
|
const ON_UUID & | ParentId () const |
|
bool | ParentIdIsLocked () const |
|
bool | ParentIdIsNil () const |
|
bool | ParentIdIsNotNil () const |
|
bool | ParentIdIsSet () const |
|
bool | ReadModelComponentAttributes (class ON_BinaryArchive &archive) |
|
unsigned int | ReferenceModelSerialNumber () const |
|
ON__UINT64 | RuntimeSerialNumber () const |
|
const ON_UUID & | SetAndLockId () |
|
bool | SetAsSystemComponent () |
|
bool | SetAsUnsetSystemComponent () |
|
bool | SetComponentType (ON_ModelComponent::Type component_component_type) |
|
bool | SetDeletedModelComponentState (bool bDeleted, class ON_ComponentManifest *manifest) |
|
void | SetHiddenModelComponentState (bool bHidden) |
|
const ON_UUID & | SetId () |
|
bool | SetId (const ON_UUID &component_id) |
|
bool | SetIdentification (const class ON_ComponentManifestItem &manifest_item, const wchar_t *manifest_name, bool bSetId, bool bParentId, bool bSetName, bool bSetIndex) |
|
bool | SetIndex (int component_index) |
|
bool | SetLocalizedSystemComponentName (const wchar_t *system_component_localized_name) |
|
void | SetLockedModelComponentState (bool bLocked) |
|
bool | SetModelComponentStatus (ON_ComponentStatus component_status) |
|
bool | SetModelSerialNumber (unsigned int model_serial_number) |
|
bool | SetModelSerialNumber (unsigned int model_serial_number, unsigned int reference_model_serial_number, unsigned int instance_definition_model_serial_number) |
|
bool | SetName (const wchar_t *component_name) |
|
bool | SetParentId (const ON_UUID &parent_id) |
|
unsigned int | SizeOf () const override |
|
bool | UndeleteName () |
|
bool | WriteModelComponentAttributes (class ON_BinaryArchive &archive, unsigned int attributes_filter) const |
|
| ON_Object () ON_NOEXCEPT |
|
| ON_Object (const ON_Object &) |
|
virtual | ~ON_Object () |
|
virtual ON_AggregateComponentStatus | AggregateComponentStatus () const |
|
bool | AttachUserData (class ON_UserData *pUserData) |
|
unsigned int | ClearAllComponentStates () const |
|
virtual unsigned int | ClearComponentStates (ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_clear) const |
|
virtual unsigned int | ClearComponentStates (ON_ComponentStatus states_to_clear) const |
|
void | CopyUserData (const ON_Object &source_object) |
|
unsigned int | CopyUserData (const ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution) |
|
virtual bool | DeleteComponents (const ON_COMPONENT_INDEX *ci_list, size_t ci_count) |
|
virtual void | DestroyRuntimeCache (bool bDelete=true) |
|
bool | DetachUserData (class ON_UserData *pUserData) |
|
void | EmergencyDestroy () |
|
class ON_UserData * | FirstUserData () const |
|
virtual unsigned int | GetComponentsWithSetStates (ON_ComponentStatus states_filter, bool bAllEqualStates, ON_SimpleArray< ON_COMPONENT_INDEX > &components) const |
|
class ON_UserData * | GetUserData (const ON_UUID &userdata_uuid) const |
|
bool | GetUserString (const wchar_t *key, ON_wString &string_value) const |
|
int | GetUserStringKeys (ON_ClassArray< ON_wString > &user_string_keys) const |
|
int | GetUserStrings (ON_ClassArray< ON_UserString > &user_strings) const |
|
bool | IsCorrupt (bool bRepair, bool bSilentError, class ON_TextLog *text_log) const |
|
bool | IsKindOf (const ON_ClassId *pClassId) const |
|
virtual void | MarkAggregateComponentStatusAsNotCurrent () const |
|
virtual void | MemoryRelocate () |
|
void | MoveUserData (ON_Object &source_object) |
|
unsigned int | MoveUserData (ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution, bool bDeleteAllSourceItems) |
|
virtual ON::object_type | ObjectType () const |
|
ON_Object & | operator= (const ON_Object &) |
|
void | PurgeUserData () |
|
virtual unsigned int | SetComponentStates (ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_set) const |
|
virtual unsigned int | SetComponentStatus (ON_COMPONENT_INDEX component_index, ON_ComponentStatus status_to_copy) const |
|
bool | SetUserString (const wchar_t *key, const wchar_t *string_value) |
|
int | SetUserStrings (int count, const ON_UserString *user_strings, bool bReplace) |
|
bool | ThisIsNullptr (bool bSilentError) const |
|
void | TransformUserData (const class ON_Xform &xform) |
|
virtual bool | UpdateReferencedComponents (const class ON_ComponentManifest &source_manifest, const class ON_ComponentManifest &destination_manifest, const class ON_ManifestMap &manifest_map) |
|
int | UserStringCount () const |
|