Rhino C++ API
8.13
|
#include <RhRdkColorButton.h>
Public Types | |
enum | eClickAction { picker, dropper } |
Public Member Functions | |
virtual CRhRdkColor | BackgroundColor (void) const =0 |
virtual CRhRdkColor | GetColor (void) const =0 |
virtual const wchar_t * | GetVariesText (void) const =0 |
virtual void | OnBeginDropper (void)=0 |
virtual void | OnBeginPicker (void)=0 |
virtual void | OnEndDropper (void)=0 |
virtual void | OnEndPicker (void)=0 |
virtual void | OnFinalEndPicker (void)=0 |
virtual void | SetBackgroundColor (const CRhRdkColor &color)=0 |
virtual void | SetChildSlotName (const wchar_t *wszChildSlotName)=0 |
virtual void | SetClickAction (eClickAction action)=0 |
virtual void | SetColor (const CRhRdkColor &color, bool bNotify)=0 |
virtual void | SetColorEx (const CRhRdkColor &color, UINT uDelayMS)=0 |
virtual void | SetNewPicker (IRhRdkColorPicker *pPicker)=0 |
virtual void | SetNotificationHandler (IRhRdkNotificationHandler *pNH)=0 |
virtual void | SetShowColorWhenDisabled (bool bShow)=0 |
virtual void | SetUndoString (const wchar_t *wszUndo)=0 |
virtual void | SetUseAlpha (bool bUseAlpha)=0 |
virtual void | SetVaries (bool bVaries)=0 |
virtual bool | ShowColorWhenDisabled (void) const =0 |
virtual bool | UseAlpha (void) const =0 |
virtual bool | Varies (void) const =0 |
Public Member Functions inherited from IRhinoUiWithController | |
virtual std::shared_ptr< IRhinoUiController > | Controller (void) const =0 |
virtual ON_UUID | ControllerId (void) const =0 |
virtual void | SetController (std::shared_ptr< IRhinoUiController > con)=0 |
Public Member Functions inherited from IRhinoUiWindow | |
virtual ON_wString | Caption (bool bAlwaysEnglish=false) const =0 |
virtual void | Delete (void)=0 |
virtual void | Enable (bool bEnable)=0 |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData)=0 |
virtual void | GetScreenCoords (ON_4iRect &rectOut) const =0 |
virtual HWND | GetWindow (void)=0 |
virtual bool | IsCreated (void) const =0 |
virtual bool | IsEnabled (void) const =0 |
virtual bool | IsShown (void) const =0 |
virtual void | Move (const ON_4iRect &rect, bool bRepaint=false, bool bRepaintBorder=false)=0 |
virtual HWND | Parent (void) const =0 |
virtual void | Refresh (bool bImmediate=false)=0 |
virtual void | SetFocus (void)=0 |
virtual void | SetParent (HWND parent)=0 |
virtual void | Show (bool bShow)=0 |
Public Member Functions inherited from IRhinoUiControllerEventWatcher | |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData)=0 |
virtual void | OnControllerActivatedEvent (IRhinoUiController &con)=0 |
virtual void | OnEvent (IRhinoUiController &con, const UUID &uuidData, IRhinoUiController::EventPriority ep, const IRhinoUiEventInfo *pInfo)=0 |
Static Public Member Functions | |
static IRhRdkColorButton * | New (RhRdkUiFrameworks f) |
Protected Member Functions | |
virtual | ~IRhRdkColorButton () |
Protected Member Functions inherited from IRhinoUiWithController | |
virtual | ~IRhinoUiWithController () |
Protected Member Functions inherited from IRhinoUiWindow | |
virtual | ~IRhinoUiWindow () |
Protected Member Functions inherited from IRhinoUiControllerEventWatcher | |
virtual | ~IRhinoUiControllerEventWatcher () |
This interface allows RDK color buttons to be used without needing MFC.
STARTING WITH RHINO 8, THIS CONTROL IS DEPRECATED AND DOES NOT WORK. See [DEPCTL]
Used by SetClickAction().
Enumerator | |
---|---|
picker | |
dropper |
|
inlineprotectedvirtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
static |
f | is the framework to use. The default, 'Auto', will automatically choose the most suitable framework. |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
Set a notification handler. RDK takes ownership of the object.
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |