Click or drag to resize

GH_ExpandMode Enumeration

Enumerates the possible expansion modes for structure paths.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_ExpandMode
Members
  Member nameValueDescription
None0 Indicates no expansion should take place.
SimpleReplace1 Paths are expanded and collisions are erased.
SimpleAppend2 Paths are expanded and merged with colliding paths.
Recursive3 Before a path is expanded, any collision is expanded first.
See Also