Click or drag to resize

IGH_DocumentObject Methods

The IGH_DocumentObject type exposes the following members.

Methods
  NameDescription
Public methodAddedToDocument
This method will be called when an object is added to a document.
Public methodAppendMenuItems
This function is called when a context menu is about to be displayed. Override it to set custom items.
Public methodCreateAttributes
Create new default attributes for this object. You should only call this function when the Attributes() field is null.
Public methodDocumentContextChanged
This method will be called when the document that owns this object moves into a different context.
Public methodExpirePreview
Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated.
Public methodExpireSolution
Call this function whenever you do something which expires the current solution. This will make sure all caches are erased, all downstream objects are expired and that the event is raised. The default implementation merely places a call to OnSolutionExpired(), override this function in derived classes to make sure you clear local data caches and expire downstream objects.
Public methodIsolateObject
Destroy all connections to other objects.
Public methodMovedBetweenDocuments
This method will be called when an object is moved from one document to another.
Public methodOnAttributesChanged
Raises the AttributesChanged event on the toplevel object.
Public methodOnDisplayExpired
Raises the DisplayExpired event on the toplevel object.
Public methodOnObjectChanged(GH_ObjectChangedEventArgs)
Raises the ObjectChanged event on the current (!not the top level!) object.
Public methodOnObjectChanged(GH_ObjectEventType)
Raises the ObjectChanged event on the current (!not the top level!) object.
Public methodOnObjectChanged(String)
Raises the ObjectChanged event on the current (!not the top level!) object.
Public methodOnObjectChanged(GH_ObjectEventType, Object)
Raises the ObjectChanged event on the current (!not the top level!) object.
Public methodOnObjectChanged(String, Object)
Raises the ObjectChanged event on the current (!not the top level!) object.
Public methodOnPingDocument
Raise the PingDocument Event on the toplevel object and try to find the document which owns this object.
Public methodOnPreviewExpired
Raises the PreviewExpired event on the toplevel object.
Public methodOnSolutionExpired
Raises the SolutionExpired event on the toplevel object.
Public methodRecordUndoEvent(GH_UndoRecord)
Record an entire undo record.
Public methodRecordUndoEvent(String)
Record a generic object change undo event.
Public methodRecordUndoEvent(String, IGH_UndoAction)
Record a specific object change undo event.
Public methodRemovedFromDocument
This method will be called when an object is removed from a document.
Public methodTriggerAutoSave
Triggers the AutoSave function on the owner document with the object_changed flag.
Public methodTriggerAutoSave(GH_AutoSaveTrigger)
Triggers the AutoSave function on the owner document with a custom flag.
Public methodTriggerAutoSave(Guid)
Triggers the AutoSave function on the owner document with the object_changed flag.
Public methodTriggerAutoSave(GH_AutoSaveTrigger, Guid)
Triggers the AutoSave function on the owner document with a custom flag.
Top
See Also