Click or drag to resize

GH_DetailView Methods

The GH_DetailView type exposes the following members.

Methods
  NameDescription
Public methodCastToT(T) (Overrides GH_GeometricGooTCastToQ(Q).)
Public methodClearCaches
Clears all volatile caches for this instance. The boundingbox is cleared, and if the detail view is referenced, the local instance of the detail view is erased.
(Overrides GH_GeometricGooTClearCaches.)
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateDetailView
Create a duplicate of this hatch.
Public methodDuplicateGeometry
Create a duplicate of this hatch.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry
If the geometry is referenced and not yet loaded, attempts to load the geometry.
(Overrides GH_GeometricGooTLoadGeometry.)
Public methodLoadGeometry(RhinoDoc)
If the detail view is referenced and not yet loaded, attempts to load the detail view.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString
Format the detail view using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
See Also