Click or drag to resize

GH_DetailView Class

Represents a Rhino model detail view. Wraps the functionality of the DetailView type.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooDetailView
    Grasshopper.Kernel.TypesGH_GeometricGooDetailView
      Grasshopper.Kernel.TypesGH_DetailView

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DetailView : GH_GeometricGoo<DetailView>

The GH_DetailView type exposes the following members.

Constructors
  NameDescription
Public methodGH_DetailView
Default constructor, creates an invalid detail view.
Public methodGH_DetailView(DetailView)
Create a duplicate of an existing detail view.
Public methodGH_DetailView(GH_DetailView)
Create a duplicate of another GH_DetailView. This constructor also copies reference data.
Public methodGH_DetailView(Guid)
Create a new referenced detail view that references a Rhino detail view with the specified ID.
Top
Properties
  NameDescription
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyIsGeometryLoaded
Gets the load state of this detail view object. The detail view is considered to be loaded when the local detail view instance is not null.
(Overrides GH_GeometricGooTIsGeometryLoaded.)
Public propertyIsValid
Gets the validity of this detail view. If the detail view is referenced but cannot be loaded, the detail view is not valid.
(Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Public propertyValue (Overrides GH_GeometricGooTValue.)
Top
Methods
  NameDescription
Public methodClearCaches
Clears all volatile caches for this instance. The boundingbox is cleared, and if the detail view is referenced, the local instance of the detail view is erased.
(Overrides GH_GeometricGooTClearCaches.)
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateDetailView
Create a duplicate of this hatch.
Public methodDuplicateGeometry
Create a duplicate of this hatch.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry(RhinoDoc)
If the detail view is referenced and not yet loaded, attempts to load the detail view.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString
Format the detail view using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also