Grasshopper API
Grasshopper API
Grasshopper.Kernel.Types
GH_SubD Class
GH_SubD Methods
AppendRenderGeometry Method
BakeGeometry Method
CastFrom Method
CastTo Method
ClearCaches Method
DestroyPreviewMeshes Method
DrawViewportMeshes Method
DrawViewportWires Method
Duplicate Method
DuplicateGeometry Method
DuplicateSubD Method
GetBoundingBox Method
GetPreviewMeshes Method
LoadGeometry Method
Morph Method
Read Method
ScriptVariable Method
ToString Method
Transform Method
Write Method
GH_SubD Methods
The
GH_SubD
type exposes the following members.
Methods
Name
Description
AppendRenderGeometry
BakeGeometry
CastFrom
(Overrides
GH_GeometricGoo
T
CastFrom(Object)
.)
CastTo
Q
(Q
)
Attempt a cast to type T.
(Inherited from
GH_GeometricGoo
T
.)
CastTo
Q
(Q
)
Attempt a cast to type Q.
(Inherited from
GH_Goo
T
.)
CastTo
T
(T
)
(Overrides
GH_GeometricGoo
T
CastTo
Q
(Q
)
.)
ClearCaches
(Overrides
GH_GeometricGoo
T
ClearCaches
.)
DestroyPreviewMeshes
DrawViewportMeshes
DrawViewportWires
Duplicate
(Overrides
GH_GeometricGoo
T
Duplicate
.)
DuplicateGeometry
(Overrides
GH_GeometricGoo
T
DuplicateGeometry
.)
DuplicateSubD
EmitProxy
Create a new proxy for this instance. Return Null if this class does not support proxies.
(Inherited from
GH_GeometricGoo
T
.)
GetBoundingBox
(Overrides
GH_GeometricGoo
T
GetBoundingBox(Transform)
.)
GetPreviewMeshes
LoadGeometry
If the geometry is referenced and not yet loaded, attempts to load the geometry.
(Overrides
GH_GeometricGoo
T
LoadGeometry
.)
LoadGeometry(RhinoDoc)
(Overrides
GH_GeometricGoo
T
LoadGeometry(RhinoDoc)
.)
Morph
(Overrides
GH_GeometricGoo
T
Morph(SpaceMorph)
.)
Read
(Overrides
GH_Goo
T
Read(GH_IReader)
.)
ScriptVariable
(Overrides
GH_Goo
T
ScriptVariable
.)
ToString
(Overrides
GH_Goo
T
ToString
.)
Transform
(Overrides
GH_GeometricGoo
T
Transform(Transform)
.)
Write
(Overrides
GH_Goo
T
Write(GH_IWriter)
.)
Top
See Also
Reference
GH_SubD Class
Grasshopper.Kernel.Types Namespace
Grasshopper for Rhino 8.18.25098.11000 (2025-04-08)
Copyright © 2009-2025 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com