GH_SubD Class |
Namespace: Grasshopper.Kernel.Types
The GH_SubD type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_SubD | Initializes a new instance of the GH_SubD class |
![]() | GH_SubD(GH_SubD) | Initializes a new instance of the GH_SubD class |
![]() | GH_SubD(Guid) | Initializes a new instance of the GH_SubD class |
![]() | GH_SubD(SubD) | Initializes a new instance of the GH_SubD class |
Name | Description | |
---|---|---|
![]() | Boundingbox | (Overrides GH_GeometricGooTBoundingbox.) |
![]() | ClippingBox | |
![]() | IsGeometryLoaded | (Overrides GH_GeometricGooTIsGeometryLoaded.) |
![]() | IsValid | (Overrides GH_GeometricGooTIsValid.) |
![]() | IsValidWhyNot |
Gets a string describing the state of "invalidness".
If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.) |
![]() | ReferenceID | (Overrides GH_GeometricGooTReferenceID.) |
![]() | TypeDescription | (Overrides GH_GooTTypeDescription.) |
![]() | TypeName | (Overrides GH_GooTTypeName.) |
![]() | Value | (Overrides GH_GeometricGooTValue.) |